[Pkg-alsa-devel] Bug#293907: libasound2: Sound Galaxy card cannot play with 1.0.8

David David <dbree@duo-county.com>, 293907@bugs.debian.org
Sun, 06 Feb 2005 13:24:57 -0600

Package: libasound2
Version: 1.0.8-1
Severity: important

Using a Sound Galaxy card, I cannot get aplay to work.  I get the
following error when I run aplay:

-------------- error message ----------------------

ALSA lib conf.c:2792:(snd_config_hook_load) "/usr/share/alsa/cards/Sound Galaxy.conf" is not a word
ALSA lib conf.c:2672:(snd_config_hooks_call) function snd_config_hook_load_for_all_cards returned error: Invalid argument
ALSA lib pcm.c:1947:(snd_pcm_open_conf) Invalid type for PCM default definition (id: default, value: cards.pcm.default)
aplay: main:508: audio open error: Invalid argument

------------ end error message ---------------------

Additional info:

I'm using alsa-modules I compiled using make-kpkg.  I first had the
1.0.7 versions for all of alsa installed, it all worked with the 1.0.7
libasound, but quit working upon upgrade to libasound2-1.0.8   .

Since then, I've installed current 1.0.8 versions of all of alsa-base,
alsa-utils, alsa-headers, and alsa-source, and recompiledalsa-modules
with these installed, but still no go. Previous to this, using various
combinations of alsa-base, etc, simply reinstalling libasound2 and
libasound2-dev version 1.0.7 restored sound.

FWIW, a 2.4.26 version of the kernel had the same problems.  (these are
also make-kpkg self-compiled.

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (900, 'testing'), (90, 'unstable')
Architecture: i386 (i586)
Kernel: Linux 2.4.27-8
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages libasound2 depends on:
ii  libc6                       2.3.2.ds1-20 GNU C Library: Shared libraries an

-- no debconf information