[Pkg-alsa-devel] Bug#293907: marked as done (libasound2: Sound Galaxy card cannot play with 1.0.8)

Debian Bug Tracking System owner@bugs.debian.org
Thu, 17 Feb 2005 17:33:03 -0800

Your message dated Thu, 17 Feb 2005 20:17:04 -0500
with message-id <E1D1wlU-0008P6-00@newraff.debian.org>
and subject line Bug#293907: fixed in alsa-lib 1.0.8-2
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 6 Feb 2005 19:24:03 +0000
>From dbree@duo-county.com Sun Feb 06 11:24:02 2005
Return-path: <dbree@duo-county.com>
Received: from mail.duo-county.com [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Cxs0o-0004uF-00; Sun, 06 Feb 2005 11:24:02 -0800
Received: from localhost.localdomain (12-135.mod.duo-county.com [])
	by bn9.blue.net (8.12.10/8.12.10/MX) with ESMTP id j16JNuUT000782;
	Sun, 6 Feb 2005 13:23:56 -0600 (CST)
Received: from dlb by localhost.localdomain with local (Exim 4.34)
	id 1Cxs1i-0002vQ-J5; Sun, 06 Feb 2005 13:24:58 -0600
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: David <dbree@duo-county.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libasound2: Sound Galaxy card cannot play with 1.0.8
X-Mailer: reportbug 3.2
Date: Sun, 06 Feb 2005 13:24:57 -0600
Message-Id: <E1Cxs1i-0002vQ-J5@localhost.localdomain>
Sender: David <dlb@localhost.localdomain>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libasound2
Version: 1.0.8-1
Severity: important

Using a Sound Galaxy card, I cannot get aplay to work.  I get the
following error when I run aplay:

-------------- error message ----------------------

ALSA lib conf.c:2792:(snd_config_hook_load) "/usr/share/alsa/cards/Sound Galaxy.conf" is not a word
ALSA lib conf.c:2672:(snd_config_hooks_call) function snd_config_hook_load_for_all_cards returned error: Invalid argument
ALSA lib pcm.c:1947:(snd_pcm_open_conf) Invalid type for PCM default definition (id: default, value: cards.pcm.default)
aplay: main:508: audio open error: Invalid argument

------------ end error message ---------------------

Additional info:

I'm using alsa-modules I compiled using make-kpkg.  I first had the
1.0.7 versions for all of alsa installed, it all worked with the 1.0.7
libasound, but quit working upon upgrade to libasound2-1.0.8   .

Since then, I've installed current 1.0.8 versions of all of alsa-base,
alsa-utils, alsa-headers, and alsa-source, and recompiledalsa-modules
with these installed, but still no go. Previous to this, using various
combinations of alsa-base, etc, simply reinstalling libasound2 and
libasound2-dev version 1.0.7 restored sound.

FWIW, a 2.4.26 version of the kernel had the same problems.  (these are
also make-kpkg self-compiled.

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (900, 'testing'), (90, 'unstable')
Architecture: i386 (i586)
Kernel: Linux 2.4.27-8
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages libasound2 depends on:
ii  libc6                       2.3.2.ds1-20 GNU C Library: Shared libraries an

-- no debconf information

Received: (at 293907-close) by bugs.debian.org; 18 Feb 2005 01:23:06 +0000
>From katie@ftp-master.debian.org Thu Feb 17 17:23:06 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1D1wrJ-0007xq-00; Thu, 17 Feb 2005 17:23:05 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1D1wlU-0008P6-00; Thu, 17 Feb 2005 20:17:04 -0500
From: Jordi Mallach <jordi@debian.org>
To: 293907-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#293907: fixed in alsa-lib 1.0.8-2
Message-Id: <E1D1wlU-0008P6-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Thu, 17 Feb 2005 20:17:04 -0500
Delivered-To: 293907-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: alsa-lib
Source-Version: 1.0.8-2

We believe that the bug you reported is fixed in the latest version of
alsa-lib, which is due to be installed in the Debian FTP archive:

  to pool/main/a/alsa-lib/alsa-lib_1.0.8-2.diff.gz
  to pool/main/a/alsa-lib/alsa-lib_1.0.8-2.dsc
  to pool/main/a/alsa-lib/libasound2-dev_1.0.8-2_i386.deb
  to pool/main/a/alsa-lib/libasound2-doc_1.0.8-2_all.deb
  to pool/main/a/alsa-lib/libasound2-plugins_1.0.8-2_i386.deb
  to pool/main/a/alsa-lib/libasound2_1.0.8-2_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 293907@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Jordi Mallach <jordi@debian.org> (supplier of updated alsa-lib package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Fri, 18 Feb 2005 01:53:09 +0100
Source: alsa-lib
Binary: libasound2-dev libasound2-plugins libasound2-doc libasound2
Architecture: source all i386
Version: 1.0.8-2
Distribution: unstable
Urgency: medium
Maintainer: Jordi Mallach <jordi@debian.org>
Changed-By: Jordi Mallach <jordi@debian.org>
 libasound2 - ALSA library
 libasound2-dev - ALSA library development files
 libasound2-doc - ALSA library developer documentation
 libasound2-plugins - ALSA library plugins
Closes: 293907 294880
 alsa-lib (1.0.8-2) unstable; urgency=medium
   * Thomas Hood:
     - Add 10_conf-space-fix.dpatch so that libasound2 works with sound
       card names containing spaces  (Closes: #294880, #293907)
 9983d36ffd98735cf14d0a4f585e93cb 861 libs optional alsa-lib_1.0.8-2.dsc
 97e0f5d263a8c07100b7a0c2148da854 12914 libs optional alsa-lib_1.0.8-2.diff.gz
 a40b77b20b68bb7ba77b77ee3388e96c 311910 libs optional libasound2_1.0.8-2_i386.deb
 140861d55db4ef32a2ac41867889a564 445344 libdevel optional libasound2-dev_1.0.8-2_i386.deb
 6f9172180e4de8da1b5c44204d594450 17924 libs optional libasound2-plugins_1.0.8-2_i386.deb
 07fe869e2990eebbfc2fd5a52ad74da0 394030 libdevel optional libasound2-doc_1.0.8-2_all.deb

Version: GnuPG v1.4.0 (GNU/Linux)