[Pkg-alsa-devel] Bug#295640: marked as done (alsa-base: cannot remove and re-autoload OSS emulation)

Debian Bug Tracking System owner@bugs.debian.org
Sun, 20 Feb 2005 08:18:42 -0800

Your message dated Sun, 20 Feb 2005 11:02:04 -0500
with message-id <E1D2tX2-0000E4-00@newraff.debian.org>
and subject line Bug#295640: fixed in alsa-driver 1.0.8-6
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 17 Feb 2005 05:07:25 +0000
>From svivanov@pdmi.ras.ru Wed Feb 16 21:07:25 2005
Return-path: <svivanov@pdmi.ras.ru>
Received: from hilbert.pdmi.ras.ru [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1D1dsq-0006Z1-00; Wed, 16 Feb 2005 21:07:24 -0800
Received: from gauss.pdmi.ras.ru (gauss.pdmi.ras.ru [])
	by hilbert.pdmi.ras.ru (8.12.3/8.12.3/Debian-7.1) with ESMTP id j1H577Gc001677
	for <submit@bugs.debian.org>; Thu, 17 Feb 2005 08:07:07 +0300
Received: (from uucp@localhost)
	by gauss.pdmi.ras.ru (8.8.8/8.8.8/Debian/GNU) with UUCP id IAA24013
	for submit@bugs.debian.org; Thu, 17 Feb 2005 08:07:01 +0300
Received: from serg by fatty with local (Exim 4.34)
	id 1D1e4e-0000ud-Jo; Thu, 17 Feb 2005 08:19:36 +0300
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Sergei Ivanov <svivanov@pdmi.ras.ru>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: alsa-base: cannot remove and re-autoload OSS emulation
X-Mailer: reportbug 3.2
Date: Thu, 17 Feb 2005 08:19:36 +0300
Message-Id: <E1D1e4e-0000ud-Jo@fatty>
X-Virus-Scanned: ClamAV 0.80/705/Fri Feb 11 19:51:32 2005
	clamav-milter version 0.80j
	on hilbert.pdmi.ras.ru
X-Virus-Status: Clean
X-Scanned-By: milter-spamc/0.10.108 (hilbert []); Thu, 17 Feb 2005 08:07:07 +0300
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: alsa-base
Version: 1.0.8-4
Severity: normal
Tags: patch

There is a couple of problems with autoloading ALSA modules.

I have one sound card, it works with the ens1371 driver. The kernel
here is compiled from Debian kernel-source-2.6.18-13, with ALSA and
OSS emulation in modules, and the real OSS not compiled at all.
I am not using udev.

On boot, no sound modules are loaded. This is good.

If I then run mpg123-oss, ALSA and OSS emulation are loaded,
and the mp3 plays. This is how it should be.

If I run alsaplayer instead, the same set of modules is loaded,
despite that OSS is not used. This is not good, unneeded stuff 
should not autoload.

Furthermore, if I remove the unused OSS emulation
(modprobe -r snd_pcm_oss) and run mpg123-oss again, it does not
work any more - `modprobe sound-slot-0' does not load the module.
This is bad - if something is auto-loaded and then removed,
I suppose it should be loadable the same way again.

I had a working auto-loading setup. It was a file (now removed)
under /etc/modprobe.d, with the following two lines:
	alias sound-slot-0 snd-ens1371
	alias snd-card-0 snd-ens1371
Installing alsa-base broke it. I don't understand why (and don't
understand why it worked, I just copied it from the kernel docs).

Anyway, the following change to /etc/modprobe.d/alsa-base fixed it.
(I still don't understand the modprobe magic involved, maybe it breaks 
something else).

--- alsa-base.orig	2005-01-31 11:51:57.000000000 +0300
+++ /etc/modprobe.d/alsa-base	2005-02-17 05:44:23.000000000 +0300
@@ -6,18 +6,14 @@
 install sound-service-0-3 modprobe snd-card-0 snd-pcm-oss
 install sound-service-0-8 modprobe snd-card-0 snd-seq-oss
 install sound-service-0-12 modprobe snd-card-0 snd-pcm-oss
-install sound-slot-0 modprobe snd-card-0
-install sound-slot-1 modprobe snd-card-1
-install sound-slot-2 modprobe snd-card-2
-install sound-slot-3 modprobe snd-card-3
-install sound-slot-4 modprobe snd-card-4
-install sound-slot-5 modprobe snd-card-5
-install sound-slot-6 modprobe snd-card-6
-install sound-slot-7 modprobe snd-card-7
-# Load optional modules above their base modules
-install snd-pcm modprobe --ignore-install snd-pcm && { modprobe snd-pcm-oss ; : ; }
-install snd-mixer modprobe --ignore-install snd-mixer && { modprobe snd-mixer-oss ; : ; }
-install snd-seq modprobe --ignore-install snd-seq && { modprobe snd-seq-oss ; modprobe snd-seq-midi ; : ; }
+install sound-slot-0 modprobe snd-card-0 && modprobe snd-pcm-oss
+install sound-slot-1 modprobe snd-card-1 && modprobe snd-pcm-oss
+install sound-slot-2 modprobe snd-card-2 && modprobe snd-pcm-oss
+install sound-slot-3 modprobe snd-card-3 && modprobe snd-pcm-oss
+install sound-slot-4 modprobe snd-card-4 && modprobe snd-pcm-oss
+install sound-slot-5 modprobe snd-card-5 && modprobe snd-pcm-oss
+install sound-slot-6 modprobe snd-card-6 && modprobe snd-pcm-oss
+install sound-slot-7 modprobe snd-card-7 && modprobe snd-pcm-oss
 # Cause a script to be run after snd-emu8000-synth module initialization
 install snd-emu8000-synth modprobe --ignore-install snd-emu8000-synth && /lib/alsa/modprobe-post-install snd-emu8000-synth
 # Cause a script to be run after card driver module initialization

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-s1
Locale: LANG=C, LC_CTYPE=ru_RU.KOI8-R (charmap=KOI8-R)

Versions of packages alsa-base depends on:
ii  alsa-utils                    1.0.8-1    ALSA utilities
ii  debconf               Debian configuration management sy
ii  debianutils                   2.8.4      Miscellaneous utilities specific t
ii  lsof                          4.71-1     List open files.
ii  module-init-tools             3.2-pre1-2 tools for managing Linux kernel mo
ii  modutils                      2.4.26-1.2 Linux module utilities

-- debconf information:
  alsa-base/alsactl_store_on_shutdown: never autosave

Received: (at 295640-close) by bugs.debian.org; 20 Feb 2005 16:08:02 +0000
>From katie@ftp-master.debian.org Sun Feb 20 08:08:02 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1D2tcn-00074Y-00; Sun, 20 Feb 2005 08:08:01 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1D2tX2-0000E4-00; Sun, 20 Feb 2005 11:02:04 -0500
From: Jordi Mallach <jordi@debian.org>
To: 295640-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#295640: fixed in alsa-driver 1.0.8-6
Message-Id: <E1D2tX2-0000E4-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sun, 20 Feb 2005 11:02:04 -0500
Delivered-To: 295640-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 4

Source: alsa-driver
Source-Version: 1.0.8-6

We believe that the bug you reported is fixed in the latest version of
alsa-driver, which is due to be installed in the Debian FTP archive:

  to pool/main/a/alsa-driver/alsa-base_1.0.8-6_all.deb
  to pool/main/a/alsa-driver/alsa-driver_1.0.8-6.diff.gz
  to pool/main/a/alsa-driver/alsa-driver_1.0.8-6.dsc
  to pool/main/a/alsa-driver/alsa-headers_1.0.8-6_all.deb
  to pool/main/a/alsa-driver/alsa-source_1.0.8-6_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 295640@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Jordi Mallach <jordi@debian.org> (supplier of updated alsa-driver package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun, 20 Feb 2005 16:34:31 +0100
Source: alsa-driver
Binary: alsa-source alsa-headers alsa-base
Architecture: source all
Version: 1.0.8-6
Distribution: unstable
Urgency: low
Maintainer: Debian ALSA Maintainers <pkg-alsa-devel@lists.alioth.debian.org>
Changed-By: Jordi Mallach <jordi@debian.org>
 alsa-base  - ALSA driver configuration files
 alsa-headers - transitional dummy package that can be safely removed
 alsa-source - ALSA driver sources
Closes: 295037 295346 295577 295640
 alsa-driver (1.0.8-6) unstable; urgency=low
   * Thomas Hood
     - /etc/init.d/alsa
       + Handle case where module "snd" is loaded but no sound card
         driver module is loaded  (Closes: #295037)
       + Sane setting of "Audigy Analog/Digital Output Jack" is on
         (Closes: #295346 and ubuntu bug #6222)
       + In order to tell whether a command is executable, use the
         which program, which is now conveniently located in /bin/
         (Closes: #295577)
       + Shorten some function names; remove some bug checks
     - alsa-base: Conflict with discover << 2.0.7-1 since versions of
       discover prior to 2.0.6-1 didn't have the /etc/discover.conf.d/
       feature which we use to implement blacklisting of OSS modules,
       and versions prior to 2.0.7-1 contained serious bugs.  Also
       Depend on debianutils >= 2.12.0 which has the which program
       in /bin/.
     - Remove sound-slot-* entries from /etc/modprobe.d/alsa-base
       (Closes: #295640)  Thanks to Sergei Ivanov for spotting this.
 0bc53a12e6baceaf193aa29acf65c56a 844 sound optional alsa-driver_1.0.8-6.dsc
 d5ab7ae49000034d118ac6c208425e30 148386 sound optional alsa-driver_1.0.8-6.diff.gz
 b6201b8e3e99126f1436ae46417aed91 110836 sound optional alsa-base_1.0.8-6_all.deb
 7026fcf576faeb2240f60c039fbdc1c6 1984342 sound optional alsa-source_1.0.8-6_all.deb
 859b241a5eee61d148e89f1662b85612 12890 sound optional alsa-headers_1.0.8-6_all.deb

Version: GnuPG v1.4.0 (GNU/Linux)