[Pkg-alsa-devel] Bug#369411: alsa-lib: FTBFS on AMD64 (32-bit link problems)

Elimar Riesebieter riesebie at lxtec.de
Mon May 29 23:13:41 UTC 2006

On Mon, 29 May 2006 the mental interface of
Ray Kohler told:

> Still does not fix it. I noticed that configure is being called with a 64-bit 
> target in configure_biarch_stamp, is this a problem?
> cd bibuild && CC="gcc -m32" LDFLAGS="-L/lib32" \
>             ../configure --prefix=/usr \
>                     --mandir=\${prefix}/share/man \
>                     --infodir=\${prefix}/share/info \
>                     --host=x86_64-linux-gnu \
>                     --enable-static --disable-maintainer-mode
> I then tried adding -rpath and/or -rpath-link in LDBIFLAGS. This caused 
> configure to fail, since the test binaries weren't executable on the build host 
> (Fails with "exec format error"). Configure really should using cross-compiler 
> mode.
> Next I tried creating a BI_DEB_HOST_GNU_TYPE (in this case, i486-pc-gnu-linux) 
> and using that as the --host type. Configure still did not enter cross-compiler 
> mode.
> I'm out of ideas at this point.

Same here. I was not involved to the biarch building discussion on
alsa-lib. Maybe Matthias Klose, who helped us much in doing this ,
can help us to solve this bug (#369411). As I understand, Jordi
hasn't time this week to contribute. So, lte's wait 'n see ;)

- explizity sent to pkg-alsa-devel at lists.alioth.debian.org as well.


  Numeric stability is probably not all that 
  important when you're guessing;-)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.alioth.debian.org/pipermail/pkg-alsa-devel/attachments/20060530/835b675a/attachment.pgp

More information about the Pkg-alsa-devel mailing list