[Pkg-alsa-devel] Bug#508470: alsa-base: Yamaha OPL3 driver does not resume properly after hibernate

Elimar Riesebieter riesebie at lxtec.de
Tue Dec 23 21:55:45 UTC 2008

* john.lindgren at tds.net [081223 20:10 +0100]
> Elimar Riesebieter <riesebie at lxtec.de> wrote: 
> > Did you tried the acpi-support package? There we have
> > resume/sunspend scripts which stop/start alsa-utils. I didn't found
> > something similar in the uswsusp package.
> Yes, I tried that.  When I use ACPI instead of APM (the kernel allows only one
> at a time), the system doesn't hibernate at all; it just blanks the screen for about
> 20 seconds and then comes back.  Same thing happens with both s2disk and
> /etc/acpi/hibernate.sh.

You can try a small script:

/etc/init.d/alsa-utils stop
and after resume /etc/init.s/alsa-utils start?

Don't know whether it works. But thats your fault.

> > From my point of view this is not an alsa bug.
> What do you think it is, then?  A hardware problem?

The fact, that /etc/init.d/alsa-utils start/stop works as expected
let me assume that it's not an alsa bug. But anyway you're free to
file a bug at https://bugtrack.alsa-project.org/alsa-bug and let us
know the bug#. We'll track it. May be you get help at
http://lists.sourceforge.net/lists/listinfo/alsa-user and
are a good starting point as well. You can cc
508470 at bugs.debian.org.

Let me know


  We all know Linux is great... it does infinite loops in 5 seconds.
        -- Linus Torvalds

More information about the Pkg-alsa-devel mailing list