[Pkg-alsa-devel] Bug#588385: [alsa-source] dmesg reports unknown symbols / disagreement with version of symbol

Guy Heatley guy.encrypt at member.fsf.org
Tue Jul 13 21:48:10 UTC 2010

Hash: SHA1

It was as simple as that!
Sound is now working on the Roland device using default drivers.

BUT ...

I had another go at compiling the source setting the env variable for root:
# export CC=/usr/bin/gcc-4.3 (Which exists!)

I ran
# m-a clean alsa-source
# m-a a-i alsa-source

This failed saying I didn't have the right version of the C compiler
installed, that matches my kernel.

I ran
# export -n CC
to delete the env var.

# m-a a-i alsa-source

This worked: built and installed the resulting modules.

depmod -a && alsa force-reload && service alsa-utils restart

But it just resulted in the usual problems ...

As you say, building the alsa-source is not required for the Roland
device, and the default drivers work, but it would be nice if the source
built modules worked as well!

Thanks for your help, in any case!

By the way - forcing the index of the soundcard to be 0 using the
/etc/modprobe.d scripts seems to have fixed the problems I was
originally having with VLC and other programs!
So another small victory for the free software user, in the end!

Best regards
- -- 

On 13/07/10 18:58, Elimar Riesebieter wrote:
> # COLUMNS=160 dpkg -l | grep alsa-modules
> <copy> the installed package to your mouse (the 2nd row)
> # dpkg --purge <paste>
> It is just simple as that ;-)
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Pkg-alsa-devel mailing list