[Pkg-alsa-devel] Bug#881715: alsa-utils: High CPU usage on the default device

Andoru aekkusu at gmail.com
Wed Dec 13 19:17:39 UTC 2017

Okay, so I installed Arch from scratch with a minimalist set-up of OpenBox
and tint2, installed alsa-utils and alsa-tools, and made that modprobe
config file to disable HDMI output, just like I did when I did the
netinstall of Debian. Then installed vlc and played all the files I played
previously (in FLAC, ogg, mp3, etc), and both when using the default device
and when selecting Analog Front Speakers subdevice, the CPU usage rarely
passes the 5% mark. I've also tried foobar2000 through wine, and got the
same result.

Here's some info about the alsa-utils package under Arch:

$ pacman -Qi alsa-utils
Name            : alsa-utils
Version         : 1.1.5-2
Description     : An alternative implementation of Linux sound support
Architecture    : x86_64
URL             : http://www.alsa-project.org
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : alsa-lib>1.0.24  pciutils  ncurses  psmisc  libsamplerate
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 2042.00 KiB
Packager        : Anatol Pomozov <anatol.pomozov at gmail.com>
Build Date      : Sat Nov 18 17:11:48 2017
Install Date    : Wed Dec 13 16:44:06 2017
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

So this makes it pretty clear that I wasn't talking out of my ass, and that
there's something fishy going on with Debian's implementation of ALSA, or
there was something fixed between versions 1.1.3 and 1.1.5.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/pkg-alsa-devel/attachments/20171213/671aa032/attachment.html>

More information about the Pkg-alsa-devel mailing list