[Pkg-alsa-devel] Bug#901689: libasound2: Fails to find configuration for Intel HDA soundcard

Ossur I Jonsson forumaccounts at ossur.xyz
Sat Jun 16 20:05:09 BST 2018

Package: libasound2
Version: 1.1.6-1
Severity: important
Tags: patch

Dear Maintainer,

On a fresh install of Debian 10 on my computer no sound devices were 
visible in the GNOME settings app, and no sound signal was being 
output from the soundcard jack. 

No pulseaudio daemon was running and the `pulseaudio -v` command 
failed to start it, showing messages about being unable to find any 
configuration for the soundcard:

I: [pulseaudio] (alsa-lib)utils.c: could not open configuration file /usr/share/alsa/ucm/HDA Intel PCH at 0xf7f10000 irq 34/HDA Intel PCH at 0xf7f10000 irq 34.conf
I: [pulseaudio] (alsa-lib)parser.c: error: could not parse configuration for card HDA Intel PCH at 0xf7f10000 irq 34
I: [pulseaudio] (alsa-lib)utils.c: could not open configuration file /usr/share/alsa/ucm/HDA Intel PCH/HDA Intel PCH.conf
I: [pulseaudio] (alsa-lib)parser.c: error: could not parse configuration for card HDA Intel PCH
I: [pulseaudio] (alsa-lib)main.c: error: failed to import HDA Intel PCH use case configuration -2
I: [pulseaudio] alsa-ucm.c: UCM not available for card HDA Intel PCH
I: [pulseaudio] alsa-util.c: Failed to set hardware parameters on plug:hw:0: Invalid argument

After reading the messages above, I dug around in the 
/usr/share/alsa folder and noticed that the configuration file for 
Intel HDA cards had a hyphen in its name. I tried adding the following 
line to /usr/share/alsa/cards/aliases.conf :

'HDA Intel' cards.HDA-Intel

Then I run `pulseaudio -v` again and now everything works, but if I
remove the line and restart the pulseaudio daemon it fails again with
the same message as before.

My proposed patch is to add  the line

'HDA Intel' cards.HDA-Intel

to src/conf/cards/aliases.conf

Best regards,
OI Jonsson

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.16.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libasound2 depends on:
ii  libasound2-data  1.1.6-1
ii  libc6            2.27-3

libasound2 recommends no packages.

Versions of packages libasound2 suggests:
ii  libasound2-plugins  1.1.6-1

-- no debconf information

More information about the Pkg-alsa-devel mailing list