[Pkg-alsa-devel] Bug#913409: libasound2: plugging in RME ADI2-DAC causes pulseaudio to crash in libasound2

Florin Iucha florin at iucha.net
Sat Nov 10 22:51:35 GMT 2018


Seems to be a duplicate. I noticed that Michael was able to test the 
patch from alsa (git). I tried to build pulseaudio and alsa from source 
to debug the issue, but I'm getting to

    libtool: link: gcc -shared  -fPIC -DPIC
    modules/alsa/.libs/libalsa_util_la-alsa-ucm.o modules/alsa/.libs/libals
    ap.o modules/.libs/libalsa_util_la-udev-util.o
    modules/.libs/libalsa_util_la-reserve-monitor.o -Wl,--whole-archive /ho
    -Wl,--no-whole-archive  -Wl,-rpath -Wl,/home/f
    lorin/tools/pulseaudio/src/.libs -Wl,-rpath
    -Wl,/usr/local/lib/pulseaudio ./.libs/libpulsecore-12.2.so
    ./.libs/libpulsecommon-12.2.so ./.libs/libpulse.so -L/ho
    -L/home/florin/tools/alsa-lib/src/control/ -ludev -ldbus-1 -lcap
    -lpthread -lrt -ldl -lm
       -g -O2   -Wl,-soname -Wl,libalsa-util.so -o .libs/libalsa-util.so
    /usr/bin/ld: .libs/libalsa-util.so: version node not found for
    symbol snd_ctl_elem_info_get_dimension@@ALSA_0.9.3

How can I test the patch? Do I need to try and re-build the package? Can 
I build alsa and pulseaudio just in some normal directories and try it 
that way?

Thank you,


On 11/10/18 2:01 PM, Elimar Riesebieter wrote:
> Control: reassign -1 libasound2-plugins 1.1.7-2
> Control: forcemerge 912921 -1
> * Florin Iucha <florin at iucha.net> [2018-11-10 12:12 -0500]:
>> Package: libasound2
>> Version: 1.1.7-1
>> Severity: grave
>> Justification: renders package unusable
>> Dear Maintainer,
>>     * What led up to the situation?
>>     Purchased a new USB DAC. It worked fine last night, then this morning
>>     it is crashing pulseaudio every time it is attached / turned on.
>>     * What exactly did you do (or not do) that was effective (or
>>       ineffective)?
>>     Plug the USB DAC.
>>     * What was the outcome of this action?
>>     Nov 10 12:03:07 herakles kernel: do_general_protection: 10 callbacks suppressed
>>     Nov 10 12:03:07 herakles kernel: traps: pulseaudio[6311] general protection ip:7f8f3e557532 sp:7fff1aa8bb20 error:0 in libasound.so.2.0.0[7f8f3e51e000+8f000]
>>     * What outcome did you expect instead?
>>     Music coming out from the headphones.
> Please check https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=912921
> Elimar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/pkg-alsa-devel/attachments/20181110/fb251c44/attachment.html>

More information about the Pkg-alsa-devel mailing list