[Pkg-bazaar-maint] Bug#559378: bzr-hg: Incorrect versioned dependency on ‘mercurial’

peter green plugwash at p10link.net
Fri Dec 4 11:34:03 UTC 2009

 Architecture: all
-Depends: bzr (>= 1.13), bzr (<< 2.1~), mercurial (>= 1.3.1), ${python:Depends}, ${misc:Depends}
+Depends: bzr (>= 1.13), bzr (<< 2.1~), mercurial (== 1.3.1), ${python:Depends}, ${misc:Depends}
 Suggests: bzr-gtk

That patch is no good for two reasons

Firstly there has never been a version 1.3.1 of the debian package only 1.3.1-1, so that dependency could never be satisfied.

Secondly debian packages need to actually be installable with the versions of thier dependencies currently in the archive.

It seems upstream have recently marked 1.4 and 1.4.1 as suported in trunk, I dunno if said changes can be safely applied to the version currently in debian though (i'm just doing some flyby investigation of rc bugs)

More information about the Pkg-bazaar-maint mailing list