[Pkg-citadel-devel] Bug#805504: Cannot log into Citadel after installation

Robert J. Clay rjclay at gmail.com
Thu Sep 28 12:18:56 UTC 2017

Control found -1 902-4
Control retitle -1 Cannot log in to Citadel after installation

    First, though, there is a seperate issue that is comeing up, as follows:

configuration setting c_default_cal_zone is empty, but must not -
check your config!

    That has already been reported and I was able to resolve it:
reference debian bug #862296 [1].

    Once past that, however there are issues that have been brought up
here in this bug that are showing up again in a newer citadel which
can be summarized as follows:

1) The administration user and its password is not getting set during
installation and so one cannot log in to the citadel server. And even
when one can get past that, by manually adding the user and setting
its password, one still cannot get logged in.  Possible because of
this issue:
2) A /etc/citadel/netconfigs directory appears be required for normal
operation but I don't know when or how that gets created, Nor what
ownership and permissions it's supposed to have. One of systems I
tried the newer version on (I've tried two;  one a hosted VM & the
other a LXC container) I manually created the directory but after
restarting citadel it appeared to be gone again.

Robert J. Clay
rjclay at gmail.com

More information about the Pkg-citadel-devel mailing list