[Pkg-clamav-devel] Bug#763300: (no subject)

Sebastian Andrzej Siewior sebastian at breakpoint.cc
Mon Sep 29 07:06:15 UTC 2014

retitle 763300 "clamscan -a -i -r -z --remove" causes a segfault

* Joe Gumbosky | 2014-09-28 19:53:34 [-0400]:

> I'm a user, not a maintainer.  I've tried running as root 

don't run it as root, never.

>and user.  No luck.  I've posted to Debian Forum
>I've reinstalled.

I tried 
|~/clamav/X/usr/share/clamav-testfiles$ clamdscan --remove clam.zip 
|/home/bigeasy/clamav/X/usr/share/clamav-testfiles/clam.zip: PUA.Win32.Packer.AcprotectUltraprotect FOUND
|/home/bigeasy/clamav/X/usr/share/clamav-testfiles/clam.zip: Removed.
|----------- SCAN SUMMARY -----------
|Infected files: 1
|Time: 0.004 sec (0 m 0 s)
|~/clamav/X/usr/share/clamav-testfiles$ ls -l clam.zip
|ls: cannot access clam.zip: No such file or directory

and haven't seen the segfault. I also tried
|clamscan -a -i -r -z --remove usr/share/clamav-testfiles/*

as suggested in forum and I also did not see the segfault.

Can you pack me your .mozilla folder so I can reproduce this crash here?
Or could you install clamav-dbg and gdb and invoke

	gdb --args clamscan -a -i -r -z --remove .mozilla/*

type "run" wait for the crash and then type "bt" and forward me the
output of it?


More information about the Pkg-clamav-devel mailing list