[Pkg-crosswire-devel] crosswire-ppa package on Kubuntu Hardy 8.04 (was: Re: Bible Time installation from the CrossWire packagers repository )

Jonathan Marsden jmarsden at fastmail.fm
Sun Jul 5 23:15:47 BST 2009

Dmitrijs Ledkovs wrote:

> Can you please fill me in on what this issue is about?

Sure.  It was originally about a difference in how BT was displaying
things for Wolfgang, but that now seems to be non-reproducible.  Now, it
is more about what happened when I tried to install crosswire-ppa as
part pf attempting to reproduce Wolfgang's issue.  I'm moving the thread
to pkg-crosswire-devel and editing its Subject: to reflect the current
focus on the crosswire-ppa package.

I'll leave my fairly detailed description of trying to install
crosswire-ppa on Kubuntu Hardy at the end of this message.

> I've recently switched to Kubuntu and now i'm using 9.04 with KDE 4.3 RC1
> The steps for kubuntu would be to download crosswire-ppa.deb which will be
> installed by KPackageKit after double clicking it.

That might well be true in Kubuntu Jaunty 9.04, but it's not what
happened when I tried it in a clean install of Kubuntu Hardy 8.04.2.

Can you please re-test your crosswire-ppa package in Kubuntu Hardy?
There is no kpackagekit in Hardy (or Intrepid), so please test on Hardy
(and Intrepid) separately from Jaunty.  A virtual machine is fine -- no
need for a spare physical machine to install Hardy (or Intrepid) on.

You *did* test crosswire-ppa on Hardy and Intrepid before putting your
crosswire-ppa packages for Hardy and Intrepid on the team PPA, right?
If not, we may need to move the crosswire-ppa packages into the
developer-testing PPA, until they have been tested.



>> (a) Install Kubuntu 8.04.2 into a fresh (virtual) machine.
>> (b) Update everything (twice, Adept had an issue the first time).
>> (c) reboot.
>> (d) Enable Hardy Backports in Adept, and update all packages it then
>> will update.
>> (e) Download
>> https://launchpad.net/~pkgcrosswire/+archive/ppa/+files/crosswire-ppa_1.6~08.04_all.deb
>> into ~/Desktop/ and double click it.  This runs GDebi and tries to
>> install it.
>> In my case, this failed, saying 43 more packages were needed (!), so I
>> gave up on the (supposedly easy) pretty GUI approach ...


More information about the Pkg-crosswire-devel mailing list