Bug#397887: Re: Bug#397887: Re: Bug#397887: [Pkg-cryptsetup-devel] Bug#397887: resume support renders system unbootable

martin f krafft madduck at debian.org
Sun Nov 12 23:24:53 CET 2006

also sprach David Härdeman <david at hardeman.nu> [2006.11.12.2308 +0100]:
> >created/setup correctly, /bin/fstype returns unknown for FSTYPE,
> >and thus the cryptroot script thinks that something went wrong
> >and loops endlessly. For some reason, mkswap didn't work. It did,
> >however, when I tried again.
> I think the reason is that you changed the script slightly when
> you rewrote it, in the attached script, the last line says "echo
> ..." while it used to say "echo -n ..." so now the passphrase
> which the swap partition was setup with included a newline so the
> first time you used your changed script you also got a different
> key for the swap partition.

Good spot. This sound plausible, we'll just assume this is what
happened. :)

> >Anyway, the problem continues to exist once I tried suspend2disk,
> >since now surely fstype doesn't recognise the partition type
> >anymore. I am not sure what the point is of verifying a valid
> >filesystem type -- fstype is never going to know about all of
> >them.
> So you did manage to boot using the script after rewriting it and
> rerunning mkswap? And then it failed after you'd done
> a suspend2disk for the first time, correct?


> >So why not just skip the $FSTYPE = unknown check and continue if
> >the mapping was set up properly?
> fstype is the only way that the initramfs script can know if
> a dm-crypt device has been setup with the right passphrase or not
> since the only thing that differences the wrong key from the right
> one is that the dm-crypt device that is setup contains gibberish.

Ouch. I guess this is fixed with luks, huh?

Anyway, so we need to add detection for uswsusp and suspend2 swap
partitions to fstype I guess...

 .''`.   martin f. krafft <madduck at debian.org>
: :'  :  proud Debian developer, author, administrator, and user
`. `'`   http://people.debian.org/~madduck - http://debiansystem.info
  `-  Debian - when you have better things to do than fixing systems
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature (GPG/PGP)
Url : http://lists.alioth.debian.org/pipermail/pkg-cryptsetup-devel/attachments/20061112/0abc0f15/attachment.pgp

More information about the Pkg-cryptsetup-devel mailing list