[Pkg-emacsen-addons] Bug#829095: dh-make-elpa: stops without any results if cannot determine version from *.el

Lev Lamberov dogsleg at debian.org
Thu Jun 30 14:15:42 UTC 2016

Package: dh-make-elpa
Version: 0.3.0
Severity: normal

Dear Maintainer,

I tried dh-make-elpa to make skeletion for ace-jump-mode
(https://github.com/winterTTr/ace-jump-mode). Ran the utility from the directory
containing source code (that is, ace-jump-mode.el) as follows:

$ dh-make-elpa --pkg-emacsen

$ dh-make-elpa

$ dh-make-elpa make

Everytime i've got the same error message:

Could not determine package version by examining *.el files at /usr/share/perl5/DhMakeELPA/Command/Packaging.pm line 233.

Lev Lamberov

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.6.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages dh-make-elpa depends on:
ii  dh-elpa                 0.0.21
ii  dh-make-perl            0.90-1
ii  libarray-utils-perl     0.5-1
ii  libfile-find-rule-perl  0.34-1
ii  libfile-grep-perl       0.02-1
ii  libgit-repository-perl  1.319-1
ii  perl                    5.22.2-1

dh-make-elpa recommends no packages.

dh-make-elpa suggests no packages.

-- no debconf information

More information about the Pkg-emacsen-addons mailing list