[Pkg-emacsen-addons] Bug#886024: emacs deb package install is hanging forever (locked file)

H.-Dirk Schmitt dirk at computer42.org
Mon Jan 1 18:49:29 UTC 2018

Package: emacsen-common, markdown-mode
Severity: important
Tags: security

On one of my machines I run in a situation there deb package
installation wasn't possible any more.

The reason was that installation of a emacs companion packge – in my
case markdown-mode – was hanging forever, without reporting any hint
what was triggering this problem.

I debuged the situation and found that the following statement is
running forever.
> `emacs24 -q -batch -l package --eval (add-to-list 'package-directory-list "/usr/share/emacs/site-lisp/elpa-src") -f package-initialize -f batch-byte-compile markdown-mode-autoloads.el markdown-mode-pkg.el markdown-mode.el`

I tried to manual execute the statement above and have seen now the

> Wrote /root/.breadcrumb …ing-c-adaptive-history locked by root at vt-xenia… (pid 5423): (s, q, p, ?)?

After seeing this the mitigation was simple:
Just start emacs as „interactive editor“ and process the same question
shown up.

Why is this a serious problem ? The answer is:

- No hint what is going wrong is visible.
- Aborting (e.g. reboot) may end up in a the following problem:
> E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. 
- In this case any further updates (including security related) may be
blocked until resolution. (That why I tagged it as security problem.)
- It is not resolvable by a 'purge and reinstall' mitigation.

More information about the Pkg-emacsen-addons mailing list