Bug#948573: exim4: TLS not in use. Log spammed with "No server certificate defined; will use a selfsigned one."

Andreas Metzler ametzler at bebt.de
Fri Jan 10 18:12:22 GMT 2020

On 2020-01-10 Graham Cobb <g+debian at cobb.uk.net> wrote:
> 2020-01-10 11:16:32 Warning: No server certificate defined; will use a
> selfsigned one.  Suggested action: either install a certificate or
> change tls_advertise_hosts option

> I do not want to create a certificate, nor do I want exim to use a
> self-signed one.  There are no SMTP listeners running and nothing
> tries to send email to this system.

> I have tried removing the tls_advertise_hosts option completely from
> the config file (verifying it is not present in
> /var/lib/exim4/config.autogenerated).

> I have also tried including it in the config as:
>  tls_advertise_hosts =

> Neither option works - exim still logs these messages.

You probably have not edited the correct file. "tls_advertise_hosts ="
does work. Please retry and check with
/usr/sbin/exim4 -bP tls_advertise_hosts

cu Andreas

More information about the Pkg-exim4-maintainers mailing list