[Pkg-exim4-users] Debian Exim Setup Problem

Thomas H. George lists at tomgeorge.info
Tue Jan 17 22:07:08 UTC 2006

Alex King wrote:

>On Mon, Jan 16, 2006 at 10:44:47AM -0500, Thomas H. George wrote:
>>I have not been able to setup exim4 so that I can send mail from Mutt 
>>over a Verizon DSL connection.  After trying numerous configurations I 
>>am confused by the distinction, if any, between the outgoing SMTP server 
>>and the Smarthost.  Certainly this is elementary but after studying 
>>README.Debian.gz and exim4-doc-html and learning to use a number of 
>>exim4 command options and logging options I still can't get an exim4 
>>setup that works.  I start from the known working Mozilla setup:
>>Account Name: lists
>>Your Name: Thomas H. George
>>email address: lists at tomgeorge.info
>>POP mail server
>>server name: mail.tomgeorge.info port 110
>>user name: lists at tomgeorge.info
>>Outgoing Server (SMTP) Settings
>>server name: outgoing.verzison.net port 25  Use TLS if available
>>user name: dryden
>>The first time this setup is used it asks for the password for 
>>lists at tomgeorge.info.  It does not require the password for the Verizon 
>>DSL account.
>>I try to duplicate this setup for exim4 by running dpkg-reconfigure 
>>Split configuration into small files?: No
>>mail sent by smarthost; received via SMTP or fetchmail
>>System mail name: tomgeorge.info
>>IP address to listen to:
>>Other destinations for which mail is accepted: Left Blank
>>Machines to relay for: Left Blank
>>Machine handling outgoing mail for this host (smarthost): 
>>Hide local name in outgoing mail: No
>>Keep number of DNS-queries minimal: No
>>In addition I have edited the file /etc/exim4/passwd.client adding a
>>With this setup and log_selector = +all tail of mainlog ends with
>>2006-01-16 09:48:39 End queue run: pid=11451
>>2006-01-16 09:58:51 cwd=/home/tom 7 args: sendmail -oem -oi -f 
>>lists at tomgeorge.info -- mail at tomgeorge.info
>>2006-01-16 09:58:51 1EyVop-0002zl-Nz <= lists at tomgeorge.info U=tom P=local 
>>S=442 id=20060116145851.GA11507 at tomgeorge.info T="From Mutt" from 
>><lists at tomgeorge.info> for mail at tomgeorge.info
>>2006-01-16 09:58:51 cwd=/var/spool/exim4 3 args: /usr/sbin/exim4 -Mc 
>>2006-01-16 09:58:52 1EyVop-0002zl-Nz == mail at tomgeorge.info R=smarthost 
>>T=remote_smtp_smarthost defer (-53): retry time not reached for any host
>>FAQ A0608 in exim4-doc-html says this is not an error but this is all I 
>>get.  After trying many variations of this setup I have three days of 
>>test messages to my other mailbox in the queue and every transmission 
>>results in this message.
>>Please straighten me out on this problem.
>>Tom George
>>PS  I have learned to delete messages in the queue with the command 
>>exim4 -Mrm <message id> and to retreive the message id's with exim4 -bp 
>>but I can't find a way delete a range of messages.  Is there such a beast?
>No, not to my knowledge.
>The problem shown in the logs above, "retry time not reached for any
>host" means that there were errors and exim is waiting before it trys
>again.  What may well have happened is that you originally had a bad
>config for a while and it couldn't send to your smarthost, so it marked
>it as bad.  Then each time you change the config and send another
>message, it doesn't re-check sending, it is still waiting for a timeout.
>If there is still one or more validly addressed mails in the queue, you
>should try to send one of them manually:
>exim4 -v -M <message-id>
>That will force exim to try to deliver the message, regartdless of the
>timeout value.  Adding -v will cause it to print the SMTP conversation
>Now if this doesn't work, cange the config and try again.  But instead
>of sending a new message each time, pick one from the queue and re-try
>it with exim4 -M <message-id>, or send one to get it in the first and do
>the exim4 -M thing.
This helped but I am still stumped.  I am fairly sure the verizon 
authenication is right because one of my changes clearly caused it to be 

The problem now is a message "No MAIL  FROM command has been issued."  
Indeed just before this there is a line:

SMTP>> MAIL FROM: <> SIZE = 2258

I thought the problem might be with my .muttrc but I tried sending mail 
directly from exim4 with the same result.  Where might the MAIL FROM 
command be?

Tom George 

More information about the Pkg-exim4-users mailing list