[Pkg-exim4-users] Problems with Exim4 in Ubuntu (Ursa Polaris)

Ursa Polaris polaris.ursa at gmail.com
Wed Jun 17 17:24:19 UTC 2009

   Yep, I am hosting mail for multiple domains, but that wasn't the
issue. I did, however, find the issue. In the exim4.2 upgrade the
Debian macros were moved around and changed in a number of ways, and
someone who maintains config files ASSUMED that "we all wanted" the
'bad user' .forward file error escaping through use of the local
delivery mechanism by adding a conditional macro to it that ONLY does
this "real-username" translation for local delivery. Which means that
any one of us who have been using it for remote relay purposes
suddenly had it break, and it took me 4 hours of hair-pulling to hunt
down the tiny little issue and simply comment out (with prejudice) any
references to the macro and the macro itself. Turns out that upgrading
from Debian to Ubuntu meant a whopping 5 minor revision jump in exim4,
so I'm sure news of this macro change is very old for any of you
dedicated and long-time Ubuntu users.

Needless to say, all of my mail is working like a dream now. And as
frustrating as exim can be at times, it's still leaps and bounds
better than sendmail and postfix in my book. =)

- Ursa

On Wed, Jun 17, 2009 at 9:39 AM, Chris
Scully<cscully at careplusfinancial.com> wrote:
> Is your mail server serving more than one domain?
> I ran into this issue when setting up exim4 and after beating my head
> against the wall for hours I finally realized I left my local domain off of
> the list of domains served when I ran dpkg-reconfigure.  I added the domain
> and everything worked fine from there.
> Chris
> pkg-exim4-users-request at lists.alioth.debian.org wrote:
>> Send Pkg-exim4-users mailing list submissions to
>>        pkg-exim4-users at lists.alioth.debian.org
>> To subscribe or unsubscribe via the World Wide Web, visit
>>        http://lists.alioth.debian.org/mailman/listinfo/pkg-exim4-users
>> or, via email, send a message with subject or body 'help' to
>>        pkg-exim4-users-request at lists.alioth.debian.org
>> You can reach the person managing the list at
>>        pkg-exim4-users-owner at lists.alioth.debian.org
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of Pkg-exim4-users digest..."
>> Today's Topics:
>>   1. Problems with Exim4 in Ubuntu (Ursa Polaris)
>> ----------------------------------------------------------------------
>> Message: 1
>> Date: Tue, 16 Jun 2009 15:39:14 -0700
>> From: Ursa Polaris <polaris.ursa at gmail.com>
>> Subject: [Pkg-exim4-users] Problems with Exim4 in Ubuntu
>> To: pkg-exim4-users at lists.alioth.debian.org
>> Message-ID:
>>        <18a1d3a20906161539w559c785md4059fc5f4d71222 at mail.gmail.com>
>> Content-Type: text/plain; charset=ISO-8859-1
>>   Hello folks! I recently migrated some web and DB systems from some
>> old machines to new servers in a facility, and everything appears to
>> have moved over smoothly except my mail services. I migrated from
>> Debian Sarge to Ubuntu 8.0 and ran a full apt-get upgrade immediately
>> after install to be up to date. Postfix (blech) was the default MTA
>> installed, so I promptly ran an apt-get install exim4-daemon-heavy
>> which installed the heavy exim4 package and all required dependencies.
>> Here's where things get fun:
>> I used sudo dpkg-reconfigure exim4-config as usual to setup my basic
>> MTA prefs; full internet MTA, set my bind addresses, my domains (I
>> host multiple but all mail for <user> goes to the same user regardless
>> of domain and that's fine) and told it not to use the split conf
>> files.
>> I then copied over my /etc/aliases file from the old server and kicked
>> exim4 with a sudo /etc/init.d/exim4 restart
>> Now when I try to send mail to regular user (with no alias, just a
>> plain account) mail works just fine
>> When I try to send to an address that has an alias with a :fail:
>> command it works fine and the fail msg is sent back to the sending
>> client
>> However, when I try to send to an alias that redirects mail from one
>> existing user to another (i.e. root: webmaster) OR when I try to send
>> to a "real-user" alias (i.e. abuse: real-admin), I get a "550
>> Unrouteable address" error from exim4.
>> I have poured over my configs between the old server and the new one,
>> and I can't find the difference. Is there some tiny setting somewhere
>> that instructs exim4 to be able to use the "real-user" alias format or
>> allow a real account to be re-routed to another real account that I
>> may have overlooked?
>> Thanks in advance!
>> - Ursa
>> ------------------------------
>> _______________________________________________
>> Pkg-exim4-users mailing list
>> Pkg-exim4-users at lists.alioth.debian.org
>> http://lists.alioth.debian.org/mailman/listinfo/pkg-exim4-users
>> End of Pkg-exim4-users Digest, Vol 47, Issue 3
>> **********************************************
> _______________________________________________
> Pkg-exim4-users mailing list
> Pkg-exim4-users at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/pkg-exim4-users

More information about the Pkg-exim4-users mailing list