[Pkg-exim4-users] something new:Re: can't send e-mail with mutt using exim4

Bernard bdebreil at teaser.fr
Mon Jan 4 15:37:36 UTC 2010

Bernard wrote:
> Ross Boylan wrote:
>> On Mon, 2010-01-04 at 13:30 +0100, Bernard wrote:
>>> anymore. I tried apt-get remove exim4 and then installed again in 
>>> the hope that I would recover default values, but the trick proved
>>> useless.
>> You need purge, not just remove, to get rid of config files. Also, the
>> controlling package is exim4-config.
> Just done it, and recuperated the default config.
> Results are now different, but no success so far in sending mail. No 
> more "unreacheable address" though.
> With that new config, my first test sent this : "mailing to remote 
> address not supported". No surprise, since I now recall that this was 
> the default config ; I already had this a few days ago, during my 
> first attempts.
> So: dpkg-reconfigure exim4-config ==> smarthost relay selected instead 
> of local mail only. However, I decided to leave in the list 
> of IP addresses where exim will listen to incoming smtp connexions, 
> since the explanation seems to indicate that it is the right choice in 
> my case.
> This being done, I made a new attempt to send mail to a distant 
> address. /var/log/mainlog said : 'smarthost defer (-36). Host lookup 
> for mail.free.fr did not complete (DNS timeout ?)
> Then I replaced 'mail.free.fr' by 'smtp.free.fr' in both exim4 conf 
> file (using dpkg-reconfigure) and in the /etc/exim4/passwd.client 
> file, setting up login and passwd as shown in the example. This time, 
> my new remote mail sending trial did not generate a message, at least 
> not right away. Mainlog said this :
> 2010-01-04 15:12:24 1NRnfU-0004SL-L2 <= bd at free.fr U=bd P=local S=500 
> id=20100104141224.GA17124 at free.fr
> nothing more. No message arrived at the destination e-mail address. 
> Three minutes later, a new message arrived at mainlog :
> 2010-01-04 15:15:33 1NRnfU-0004SL-L2 smtp.free.fr [] 
> Connection timed out
> 2010-01-04 15:15:33 1NRnfU-0004SL-L2 == jacques.julien78 at orange.fr 
> R=smarthost T=remote_smtp_smarthost defer (110): Connection timed out.
> I will keep trials and keep you informed. By the way, I recalled that, 
> at the very beginning (before Xmas), the few attempts that had lead to 
> positive results in sending mail to remote addresses, had not required 
> any smtp login and passwd.
Something new : ONE message has arrived to distant e-mail address. But 
not from free.fr. As said, I manage 3 e-mail addresses on this computer, 
on three different ISPs, and my tests are being carried from one address 
to the other. Since I so often received mainlog notices that 
smtp.free.fr kept defferring my messages, I tried changing my exim 
config so that 'teaser.fr' was taken into account instead of free. For 
the first trial, I did not settle any login and password for 
smtp.teaser.fr, and I even renamed the /etc/exim4/passwd.client so that 
it be not taken into account. The sent message did arrive, this time ! 
However, I am supposed to use a login and passwd to connect to 
smtp.teaser.fr, but, maybe something in my general config says that 
teaser is my default mailbox... Still, my wish is to send mails from 
free.fr whenever I use mutt : how shall I do that ? smtp.free.fr does 
not seem to be an alias :

$ host smtp.free.fr
smtp.free.fr has address

maybe I could use the IP address in the conf files... As for the port 
number, it is supposed to be default, that is 25, while for teaser.fr it 
is 587, and I had to write this in reconfiguring exim4-config, that is : 
smtp.teaser.fr::587, it wouldn't operate without that. Port 587 did not 
work with smtp.free.fr, so I left default, but this wouldn't work either.

More information about the Pkg-exim4-users mailing list