[Pkg-exim4-users] smtps support in Stretch

Gary Dale garydale at torfree.net
Mon Apr 11 00:23:52 UTC 2016

I'm running stretch on and AMD64 system and an old problem resurfaced.
My ISP uses smtps on port 465 for encrypted smtp connections. I had
solved this a year ago by adding "protocol = smtps" to
/etc/exim4/exim4.conf.template and reconfiguring. However this now
doesn't seem to work.
According the Exim wiki at
I should be adding instead the line
   tls_on_connect_ports = 465

but that doesn't seem to be helping. Mail still shows as frozen in the

I'm not sure at what point Exim4 stopped working because I don't use the
mail command very often.

The Debian documentation at https://wiki.debian.org/GmailAndExim4
suggests that I add the protocol line to
30_exim4-config_remote_smtp_smarthost in /etc/exim4/conf.d/transport,
which seems odd. I thought those would be overwritten when Exim4 is
reconfigured but after trying it, it doesn't seem to be happening - even
when I split the config into small files as per dpkg-reconfigure
exim4-conf. However it also didn't work - just like it didn't work a
year ago when I also tried it.

Any ideas?

More information about the Pkg-exim4-users mailing list