[Pkg-fonts-devel] Building fontforge

Ralf Stubner ralf.stubner at physik.uni-erlangen.de
Wed Apr 12 18:59:48 UTC 2006

On Wed, Apr 12, 2006 at 08:28 +0200, Christian Perrier wrote:
> gcc -Wall -g -O2 -I/usr/include/freetype2/ -I/usr/include/libxml2/ -I../inc -I. -I. -Wmissing-prototypes -Wunused -Wimplicit -Wreturn-type -Wparentheses -Wformat -Wchar-subscripts -I/usr/X11R6/include -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DHAVE_ICONV_H=1 -D_NO_XKB=1 -D_HAS_LONGLONG=1 -DHAVE_LIBINTL_H=1 -DNODYNAMIC=1 -D_STATIC_LIBUNINAMESLIST=1 -DFONTFORGE_CONFIG_DEVICETABLES=1  '-DSHAREDIR="/usr/share/fontforge"' -DLIBDIR='"/usr/lib"' '-DPREFIX="/usr"'   -c -o freetype.o freetype.c
> freetype.c:89:32: error: internal/internal.h: Aucun fichier ou répertoire de ce type

What version of freetype do you have installed? I remember vaguely some
discussions on fontforge-devel concerning problems to build fontforge
with recent (CVS?) versions of freetype.

I have just tried to backport libuninameslist-20050712 and
fontforge-0.0.20060406 to sarge using debhelper from backports.org. That
worked without any problems. Linking with libuninameslist does work
correctly. I haven't done much testing of this version, though. BTW,
should libuninameslist get a 0.0.<date> version number, too?


More information about the Pkg-fonts-devel mailing list