[Pkg-fonts-devel] Bug#776627: fonts-misaki: GD (ruby-gd) fails to render Misaki font package in Debian, but works with latest upstream.

Taisuke Yamada tai at rakugaki.org
Fri Jan 30 10:03:53 UTC 2015

Package: fonts-misaki
Version: 11-20080603-15
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

     I tried to render text with GD graphics library (ruby-gd, which
     uses libgd3 internally), and noticed rendering of Misaki font fails.

   * What exactly did you do (or not do) that was effective (or

     Following code works (= renders) with all installed TTFs, but Misaki.

--- cut here --- cut here --- cut here ---
# Quick test to see if GD can draw string with given TTF file.
require 'GD'

image = GD::Image.new(640, 480)
white = image.colorAllocate(0xff, 0xff, 0xff)
black = image.colorAllocate(0x00, 0x00, 0x00)

ARGV.each do |ttf|
  ret = image.stringFT(black, ttf, 12, 0, 100, 100, "ABC");
  puts "#{ret[0]}: #{ttf}" unless ret[0].nil?
--- cut here --- cut here --- cut here ---

   I was able to workaround the issue by downloading latest TTF from
   upstream website:

   - http://www.geocities.jp/littlimi/misaki.htm
   - http://www.geocities.jp/littlimi/arc/misaki/misaki_ttf_2012-06-03.zip

   With latest TTF, above code worked without an error.

   * What was the outcome of this action?

   $ echo /usr/share/fonts/truetype/*/*.ttf | wc -w
   $ ./font-test-with-gd.rb /usr/share/fonts/truetype/*/*.ttf
   Could not set character size: /usr/share/fonts/truetype/misaki/misaki.ttf
   Could not set character size: /usr/share/fonts/truetype/misaki/misakimn.ttf

   * What outcome did you expect instead?
   I expected Misaki font to render successfully, without an error.

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (600, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386, mipsel

Kernel: Linux 3.13-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: unable to detect

Versions of packages fonts-misaki depends on:
ii  dpkg  1.17.23

fonts-misaki recommends no packages.

fonts-misaki suggests no packages.

-- no debconf information

More information about the Pkg-fonts-devel mailing list