[Pkg-fonts-devel] Bug#859913: fonts-droid-fallback does not properly replace fonts-droid

Juha Heinanen jh at tutpro.com
Sun Apr 9 08:54:33 UTC 2017

Package: fonts-droid-fallback
Version: 1:6.0.1r16-1.1

I installed Debian stretch and started emacs where I have setting:

(set-frame-font "-unknown-Droid Sans Mono-normal-normal-normal-*-*-*-*-*-m-0-iso10646-1")

This has worked fine in Debian Jessie, but the font does not anymore
exist in Stretch and I get error message when I start emacs:

error: Font not available, #<font-spec nil unknown Droid Sans Mono nil iso10646-1 normal normal normal nil nil 100 0 ((:name . -unknown-Droid Sans Mono-normal-normal-normal-*-*-*-*-*-m-0-iso10646-1) (:user-spec . -unknown-Droid Sans Mono-normal-normal-normal-*-*-*-*-*-m-0-iso10646-1))>

I then tried to install fonts-droid package from Jessie, but that failed

  Replaced by files in installed package fonts-droid-fallback (1:6.0.1r16-1.1) ...
  dpkg: dependency problems prevent configuration of fonts-droid:
   fonts-droid-fallback (1:6.0.1r16-1.1) breaks fonts-droid (<< 1:6.0.0r26-1~) and is installed.

Could you, please, include Droid Sans Mono to fonts-droid-fallback
package or let people know what name they should use instead of 'Droid
Sans Mono'.

-- Juha

More information about the Pkg-fonts-devel mailing list