Bug#656334: garbled screen on browser, image viewer when scrolling(slow also)

prakash j kokkkattu pkokkattu at rediffmail.com
Wed Jan 18 14:37:07 UTC 2012

Package: mutter
Version: 3.2.1-2
Severity: important

Dear Maintainer,

I have a Nvidia 7300GT Graphics card based system and uses latest nvidia proprietary drivers. After upgrading to Gnome3(gnome-shell), image rendering and browsing has become difficult due to frequent garbled and slow rendering. the problem is faced with image viewing applications, iceweasel browser(especially).
Here is a Screenshot:
I have recorded what is happening when I scroll with My usb mouse through web page. Here is the link(Zip format 4MB file):
More info:

 * What led up to the situation?
Using a Debian Testing+Sid system. upgraded to Gnome3 3.0 and started facing this issue where, while slowly scrolling with mouse, webpages and images looks garbled,freezed. web page returns to normal, if I launch any application or scroll a little up or down. upgraded to Gnome-3.2 from Sid along with related packages still facing the problem. 
Note that, in Gnome "Classic"(fallback) Session, either with metacity or compiz window manager, This bug is not found. however, if I try "mutter --replace" on fallback session, bug reoccurs(in fallback session).
I tried "gnome-shell --replace" from a terminal and the output shows error related to "clutter". Please see the debug output here:

 * What exactly did you do (or not do) that was effective (or
I rebuilt mutter-3.2.1 from Ubuntu for Debian and tried it. but it did not resolved. faced the same garbling and slow page rendering. 
Then, I reinstalled Debian libmutter0 and updated Nvidia drivers(295.09-1) from Debian Experimental Repository. This also did not work.
As a Last resort, I tried nouveau driver. with nouveau driver, Gnome-3.2 shell is working fine. 
 * What was the outcome of this action?
with nouveau driver, Gnome-shell works fine. all other options failed. the issueis with libmutter0/gnome-shell interacting with nvidia proprietary drivers.

Please ask for any more info needed,

-- System Information:
Debian Release: wheezy/sid
 APT prefers testing
 APT policy: (990, 'testing'), (300, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-8.dmz.1-liquorix-amd64 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_GB.utf8, LC_CTYPE=en_GB.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libmutter0 depends on:
ii libatk1.0-0 2.2.0-2
ii libc6 2.13-24
ii libcairo-gobject2 1.10.2-6.2
ii libcairo2 1.10.2-6.2
ii libcanberra-gtk3-0 0.28-3
ii libcanberra0 0.28-3
ii libclutter-1.0-0 1.8.2-2
ii libcogl-pango0 1.8.2-1
ii libcogl5 1.8.2-1
ii libdrm2 2.4.30-1
ii libffi5 3.0.10-3
ii libfontconfig1 2.8.0-3
ii libfreetype6 2.4.8-1
ii libgconf2-4 3.2.3-1
ii libgdk-pixbuf2.0-0 2.24.0-2
ii libgirepository-1.0-1 1.31.1-1
ii libgl1-mesa-glx [libgl1] 7.11.2-1
ii libglib2.0-0 2.30.2-4
ii libgtk-3-0 3.2.3-1
ii libice6 2:1.0.7-2
ii libjson-glib-1.0-0 0.14.2-1
ii libpango1.0-0 1.29.4-2
ii libsm6 2:1.2.0-2
ii libstartup-notification0 0.12-1
ii libx11-6 2:1.4.4-4
ii libxcomposite1 1:0.4.3-2
ii libxcursor1 1:1.1.12-1
ii libxdamage1 1:1.1.3-2
ii libxext6 2:1.3.0-3
ii libxfixes3 1:5.0-4
ii libxi6 2:1.4.5-1
ii libxinerama1 2:1.1.1-3
ii libxrandr2 2:1.3.2-2
ii libxrender1 1:0.9.6-2
ii mutter-common 3.2.1-2

 Installed: 295.09-1

 Installed: 3.2.1-8
libmutter0 recommends no packages.

libmutter0 suggests no packages.

-- no debconf information

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20120118/13b1a26a/attachment-0001.html>

More information about the pkg-gnome-maintainers mailing list