Bug#806772: python3-gi: setup.py test (in packages using gi) doesn't find it

Matthias Urlichs matthias at urlichs.de
Tue Dec 1 04:48:42 UTC 2015

Package: python3-gi
Version: 3.18.2-2
Severity: normal

$ python3 setup.py test
Searching for gi>=3.12
Reading https://pypi.python.org/simple/gi/
No local packages or download links found for gi>=3.12
error: Could not find suitable distribution for Requirement.parse('gi>=3.12')
$ dpkg -l python3-gi
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                    Version          Architecture     Description
ii  python3-gi              3.18.2-2         amd64            Python 3 bindings for gobject-introspection librarie

My setup.py:

import logging
logger = logging.getLogger(__name__)

# setup.py for etcTree

from sys import version
import os
#from etctree import VERSION

from setuptools import setup


if version < '3.4':
    sys.exit('Error: Python-3.4 or newer is required. Current version:\n %s'
             % sys.version)

    name = name,
    version = VERSION,
    description = 'Dynamic etcd state',
    long_description = '''\
etcTree is a dynamic, object-oriented view of an etcd (sub)tree
with bi-directional updates.
    author = 'Matthias Urlichs',
    author_email = 'matthias at urlichs.de',
    url = 'https://github.com/m-o-a-t/etctree',
    download_url = 'http://netz.smurf.noris.de/cgi/gitweb?p=etctree.git;a=snapshot;h=master',
    license = 'GPL',

    zip_safe = False, 
    packages = ('etctree',),
    package_data = { '': ['*.glade']},
    install_requires = """\
gi >= 3.12

-- System Information:
Debian Release: 8.2
  APT prefers stable
  APT policy: (700, 'stable'), (650, 'testing'), (600, 'unstable'), (550, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.0.0-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages python3-gi depends on:
ii  gir1.2-glib-2.0        1.46.0-2
ii  libc6                  2.19-18+deb8u1
ii  libffi6                3.1-2+b2
ii  libgirepository-1.0-1  1.46.0-2
ii  libglib2.0-0           2.46.2-1
ii  python3                3.5.0-2

python3-gi recommends no packages.

python3-gi suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list