Bug#849525: gvfs-bin: gvfs insists on password to mount samba shares which have no password

Markus Hamilton hamilton-engineering at epbfi.com
Wed Dec 28 05:58:35 UTC 2016

Package: gvfs-bin
Version: 1.22.2-1
Severity: important

I cannot access samba shares which do not require a password. The problem was
discovered using pcmanfm (LXDE desktop) as well as with caja (MATE desktop).
Both programs probably use gvfs-mount to mount samba shares.
To confirm, I tried gvfs-mount in a terminal window:
gvfs-mount smb://servername/sharename
gvfs-mount asks for user, domain and password. Entering an empty password is
impossible. gvfs-mount asks again. To make sure that this is not a samba
problem, I tried to mount the samba share with "mount":
sudo mount -t cifs //servername/sharename /mnt -o username=markus,password=""
This works without a problem. It is just not useful. Users want to use the
builtin funtionality of their file managers.

-- System Information:
Debian Release: 8.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gvfs-bin depends on:
ii  gvfs-common   1.22.2-1
ii  libc6         2.19-18+deb8u6
ii  libglib2.0-0  2.42.1-1+b1

gvfs-bin recommends no packages.

Versions of packages gvfs-bin suggests:
ii  gvfs  1.22.2-1

-- no debconf information

More information about the pkg-gnome-maintainers mailing list