Bug#811078: gedit-plugins: Python related depends too tight: Causes problems during transitions
debian at kitterman.com
Fri Jan 15 13:47:36 UTC 2016
Currently, gedit-plugins gets python3 interpreter depends like this (when
built with python3.4 as default python3):
python3 (<< 3.5), python3 (>= 3.4~), python3.4
As a result, gedit-plugins became uninstallable once the default was updated
to python3.5. While a binNMU corrected this, it's entirely unnecessary. I
looked and there's no compiled python extensions in the plugins, it's all
arch all python that does not need rebuilding when the version changes.
Ths problem is that because dh_python3 was being called for all plugins, some
of which are compiled, dh_python treated them as python3 extensions for
Please see the attached patch that addresses this issue. With it the python3
interpreter depend is:
python3:any (>= 3.3.2-2~)
No more trouble during transitions, the package is always installable. This
fixes the exact problem that led to #810866 being filed.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 3183 bytes
Desc: not available
More information about the pkg-gnome-maintainers