Bug#862249: Mounting an SFTP share with path may lead to data being deleted

Jason Crain jason at inspiresomeone.us
Wed May 10 14:42:21 UTC 2017

On Wed, May 10, 2017 at 10:42:51AM +0200, Jonas Meurer wrote:
> I just discovered a severe bug in the sftp protocol support of nautilus:
> I tried to mount a remote folder via SFTP/SSH by using a syntax similar
> to the following:
> 'sftp://<host>/path/to/directory'. Instead of displaying
> '/path/to/directory' on the remote host, nautilus kept giving warnings
> that it doesn't know what to do with file 'directory' and moved to the
> home directory on the remote host.
> I tried it with different syntax (colon between host and path, 'user@'
> in front of host, using 'ssh://' instead of 'sftp://') and I tried both
> using the 'Andere Orte' (something like 'different locations' in
> english) and the address bar (<Ctrl>+<l>). One time nautilus even
> crashed (the Files window got closed).
> After some time, I went back to the remote console SSH session and was
> shocked to realize that the whole directory '/path/to/directory' was
> removed on the remote host. Luckily I had backups.
> I don't have time to do further debugging right now as I'm quite busy,
> but I will do further debugging and try to find a clear reproducer in
> the following days.

Please do try to find a way to reproduce this.  I suspect that nautilus'
warning messages may be caused by the path being missing or a filesystem
problem, instead of nautilus deleting the path.  I've tried opening
paths in nautilus several ways and I can't find any problem with it.

More information about the pkg-gnome-maintainers mailing list