Bug#928668: gnome-keyring: passphrase prompt in GNOME 3 does not take correct passphrase for ed25519 key

Yao Wei (=?UTF-8?Q?=E9=AD=8F=E9=8A=98=E5=BB=B7?=) mwei at debian.org
Wed May 8 15:30:05 BST 2019

Package: gnome-keyring
Version: 3.28.2-5
Severity: normal


The passphrase prompt in GNOME3 cannot take correct passphrase if the
ssh key is ed25519.

Here's the procedure I tried:

1. Generate an ed25519 key with ssh-keygen
2. Copy the public key to a remote host
3. ssh to the remote and password prompt in GNOME 3 appears
4. Enter correct password but the prompt appears again, probably
   somewhere between gnome-keyring-daemon and the password prompt does
   not take the password.

Note that ssh-add, with passphrase prompt in the command line, does
work, therefore this is not the same issue as bug #738660.

Also, rsa4096 key also does work.

I haven't tried using experimental yet, but this is the same version
used in buster, hence the report.

Thank you,
Yao Wei

-- System Information:
Debian Release: 10.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gnome-keyring depends on:
ii  dbus-user-session [default-dbus-session-bus]  1.12.12-1
ii  dbus-x11 [dbus-session-bus]                   1.12.12-1
ii  dconf-gsettings-backend [gsettings-backend]   0.30.1-2
ii  gcr                                           3.28.1-1
ii  libc6                                         2.28-10
ii  libcap-ng0                                    0.7.9-2
ii  libcap2-bin                                   1:2.25-2
ii  libgck-1-0                                    3.28.1-1
ii  libgcr-base-3-1                               3.28.1-1
ii  libgcrypt20                                   1.8.4-5
ii  libglib2.0-0                                  2.58.3-1
ii  p11-kit                                       0.23.15-2
ii  pinentry-gnome3                               1.1.0-2

Versions of packages gnome-keyring recommends:
ii  gnome-keyring-pkcs11  3.28.2-5
ii  libpam-gnome-keyring  3.28.2-5

gnome-keyring suggests no packages.

-- no debconf information
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://alioth-lists.debian.net/pipermail/pkg-gnome-maintainers/attachments/20190508/ecae6f30/attachment.sig>

More information about the pkg-gnome-maintainers mailing list