Bug#928893: gnome-disk-utility: disk content permamently lost when changing LUKS password

Svjatoslav Agejenko svjatoslav at svjatoslav.eu
Sun May 12 18:56:02 BST 2019

Package: gnome-disk-utility
Version: 3.30.2-3
Severity: important

Dear Maintainer,

   * What led up to the situation?

Install system using normal full disk encryption LUKS+Ext4.
After install open gnome-disk-utility and change
encryption password. It gives some error dialog and
now you are royally screwed. It deleted the only
LUKS keyslot. Cannot add new keyslots because of that.
All data will be lost after reboot.

Here is output of luksdump:

udo cryptsetup luksDump /dev/sda5
LUKS header information
Version:        2
Epoch:          4
Metadata area:  16384 [bytes]
Keyslots area:  16744448 [bytes]
UUID:           3c16ad4c-294c-4547-bf3e-bb8864ba5ea3
Label:          (no label)
Subsystem:      (no subsystem)
Flags:          (no flags)

Data segments:
  0: crypt
        offset: 16777216 [bytes]
        length: (whole device)
        cipher: aes-xts-plain64
        sector: 512 [bytes]

  0: pbkdf2
        Hash:       sha256
        Iterations: 59904
        Salt:       XX XX XX XX XX ....
        Digest:     XX XX XX XX XX ...


I changed salt and digest. No Keyslots are present!!!

I tried this 2 times in a row with new install,
exactly same result.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.0.8-xanmod5 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8), LANGUAGE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gnome-disk-utility depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.30.1-2
ii  libatk1.0-0                                  2.30.0-2
ii  libc6                                        2.28-10
ii  libcairo2                                    1.16.0-4
ii  libcanberra-gtk3-0                           0.30-7
ii  libdvdread4                                  6.0.1-1
ii  libgdk-pixbuf2.0-0                           2.38.1+dfsg-1
ii  libglib2.0-0                                 2.58.3-1
ii  libgtk-3-0                                   3.24.5-1
ii  liblzma5                                     5.2.4-1
ii  libnotify4                                   0.7.7-4
ii  libpango-1.0-0                               1.42.4-6
ii  libpangocairo-1.0-0                          1.42.4-6
ii  libpwquality1                                1.4.0-3
ii  libsecret-1-0                                0.18.7-1
ii  libsystemd0                                  241-3
ii  libudisks2-0                                 2.8.1-4
ii  udisks2                                      2.8.1-4

gnome-disk-utility recommends no packages.

gnome-disk-utility suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list