Bug#951875: deja-dup install python-gi not python3-gi python2.7 is outdated

Michaël Parchet mparchet at sunrise.ch
Sat Feb 22 15:42:51 GMT 2020

Package: deja-dup
Version: 38.3-1
Severity: important

Dear Maintainer,

*** Reporter, please consider answering these questions, where 
appropriate ***

    * What led up to the situation?
    * What exactly did you do (or not do) that was effective (or
    * What was the outcome of this action?
    * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: bullseye/sid
   APT prefers stable-updates
   APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.4.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages deja-dup depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.34.0-2
ii  duplicity                          
ii  libatk1.0-0                                  2.34.1-1
ii  libc6                                        2.29-10
ii  libglib2.0-0                                 2.62.4-2
ii  libgoa-1.0-0b                                3.34.1-1
ii  libgoa-backend-1.0-1                         3.34.1-1
ii  libgtk-3-0                                   3.24.13-1
ii  libnautilus-extension1a                      3.34.1-1
ii  libpackagekit-glib2-18                       1.1.13-2
ii  libpango-1.0-0                               1.42.4-8
ii  libpeas-1.0-0                                1.22.0-5
ii  libsecret-1-0                                0.19.1-1

Versions of packages deja-dup recommends:
ii  gvfs-backends  1.42.2-1
ii  packagekit     1.1.13-2
ii  policykit-1    0.105-26

Versions of packages deja-dup suggests:
pn  python-boto         <none>
pn  python-cloudfiles   <none>
pn  python-swiftclient  <none>

-- no debconf information

step to reproduce
1. open for first time deja.dup
2. configure backup directory
3. select nextactual resultThe following packages have unmet dependencies:
   python-gi: Depends: gir1.2-glib-2.0 (>= 1.39.0) but it is not going 
to be installed
              Depends: libgirepository-1.0-1 (>= 1.44.0) but it is not 
going to be installe

deja-dup ask to install python-gi package (python2.7 is depreceted) and
dependebce isen't unstallable
expended result
deja-dup sould ask to install python3-gi package

could you help me please to fix this issue ?

Best regards


More information about the pkg-gnome-maintainers mailing list