Bug#975349: rhythmbox-plugins: Broken Dependency - Requires both Python to be << 3.9 and >= 3.8~

Brett brett.daniel.collins at gmail.com
Fri Nov 20 19:42:01 GMT 2020

Package: rhythmbox-plugins
Version: 3.4.4
Severity: important
X-Debbugs-Cc: brett.daniel.collins at gmail.com

Dear Maintainer,

Rhythmbox-plugins currently is a required package for GNOME - however it is uninstallable when python3.9 is on the system due to dependencies being both >= 3.8~ and << 3.9

This prevents GNOME from being installed on Debian Sid. 

-- System Information:
Debian Release: bullseye/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'oldstable-updates'), (500, 'unstable'), (500, 'testing'), (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.9.0-3-amd64 (SMP w/4 CPU threads)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages rhythmbox-plugins depends on:
ii  gir1.2-glib-2.0          1.66.1-1+b1
pn  gir1.2-gnomekeyring-1.0  <none>
ii  gir1.2-gstreamer-1.0     1.18.1-1
ii  gir1.2-gtk-3.0           3.24.23-2
ii  gir1.2-peas-1.0          1.28.0-2+b1
pn  gir1.2-rb-3.0            <none>
ii  gir1.2-secret-1          0.20.3-1
ii  gir1.2-webkit2-4.0       2.30.2-1
ii  libc6                    2.31-4
ii  libdmapsharing-3.0-2     2.9.41-3
ii  libgdk-pixbuf2.0-0       2.40.0+dfsg-5
ii  libglib2.0-0             2.66.3-1
pn  libgpod4                 <none>
ii  libgrilo-0.3-0           0.3.13-1
ii  libgstreamer1.0-0        1.18.1-1
ii  libgtk-3-0               3.24.23-2
ii  libgudev-1.0-0           234-1
ii  libimobiledevice6        1.3.0-5+b1
ii  libjson-glib-1.0-0       1.6.0-1
ii  liblirc-client0          0.10.1-6.2+b1
ii  libmtp9                  1.1.17-3
ii  libnotify4               0.7.9-1
ii  libpango-1.0-0           1.46.2-3
ii  libpeas-1.0-0            1.28.0-2+b1
ii  librhythmbox-core10      3.4.4-3.1
ii  libsecret-1-0            0.20.3-1
ii  libsoup2.4-1             2.72.0-2
ii  libtotem-plparser18      3.26.5-5
ii  python3                  3.9.0-3
ii  python3-gi               3.38.0-1+b1
pn  python3-mako             <none>
ii  python3.5                3.5.3-1+deb9u3
pn  python3.7                <none>
ii  python3.8                3.8.6-1
ii  rhythmbox                3.4.4-3.1
ii  zeitgeist-core           1.0.2-3

rhythmbox-plugins recommends no packages.

rhythmbox-plugins suggests no packages.

More information about the pkg-gnome-maintainers mailing list