Bug#971812: gegl: version in buster not compatible with libc6 from bullseye

Adrian Bunk bunk at debian.org
Fri Jul 16 11:24:07 BST 2021

Control: reassign -1 libc6
Control: affects -1 libgegl-0.4-0
Control: close -1 2.31-9

On Wed, Oct 07, 2020 at 08:50:01PM +0100, Simon McVittie wrote:
> This is because you are using the version of libc6 from testing (bullseye)
> on a mostly-buster system, and the version of libgegl in buster has
> assumptions that mean it works fine in buster, but breaks when libc6
> is upgraded. Mixing packages from stable and testing is not something
> that anyone can guarantee will work flawlessly.
> This is not going to be something that can change in buster, unless the
> release team would accept a stable-update that changes how libgegl is
> linked in order to future-proof it against people upgrading core system
> libraries to versions 18 months newer. I'm not sure they're going to go
> for that, but I'll ask...

Such problems can be solved with a Breaks in the opposite direction,
and this has already been done in bullseye for this bug:

glibc (2.31-9) unstable; urgency=medium
  * debian/control.in/libc: add a Breaks: against libgegl-0.4-0 (<< 0.4.18).
    Closes: #968349.

 -- Aurelien Jarno <aurel32 at debian.org>  Tue, 05 Jan 2021 06:47:42 +0100

>     smcv


More information about the pkg-gnome-maintainers mailing list