[pkg-gnupg-maint] Bug#795639: assword fails with "Decryption error: Decryption failed"

demure demure at sdf.org
Tue Oct 13 21:59:28 UTC 2015

These two commands have fixed gpg 2.1.8 for me, on sid.

Prior to the fix, I had:
gpg: decryption failed: No secret key

On Sun, 16 Aug 2015 10:16:03 -0700 Russ Allbery <rra at debian.org> wrote:
> Daniel Kahn Gillmor <dkg at fifthhorseman.net> writes:
> Aha.  Okay, I seem to have fixed it, although I still don't really
> understand what happened.  On a hunch, I ran:
> $ gpg2 --import ~/.gnupg/pubring.gpg
> That spat out a bunch of output (tons and tons of those legacy key
> messages), and then I ran:
> $ gpg2 --import ~/.gnupg/secring.gpg
> -- 
> Russ Allbery (rra at debian.org)               <http://www.eyrie.org/~eagle/>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/pkg-gnupg-maint/attachments/20151013/ac1ec404/attachment.html>

More information about the pkg-gnupg-maint mailing list