[pkg-gnupg-maint] Bug#842015: Bug#842015: Similar issue, no emacs

Eduard Bloch edi at gmx.de
Tue Nov 1 09:29:40 UTC 2016

Hallo dkg,
* Daniel Kahn Gillmor [Mon, Oct 31 2016, 09:02:10PM]:
> Hi Eduard--
> thanks for commenting on https://bugs.debian.org/842015.

You are welcome.

> > this has been happening to me for a couple of days now. Restarting
> > gpg-agent does not help.
> Are you saying that gpg is unable to use any secret key material,
> reproducibly, for several days?  or that it's intermittent for you?

I am not sure, it behaves weird. Sometimes I cannot open messages in
mutt, it seems to hang. And pressing Ctrl-C releases it and the message
is suddenly displayed like there was no problem and the check result
says "verified correctly". But I guess that issue is unrelated and
deserves separate investigation.

The problem at the moment is that on the same machine (which I used via
remote link in the last days) it was not working with the same symptoms,
although all other X11 programs did work. Thinking again... (and see
below) maybe it's displaying the pin entry window on the locked screen,
ignoring the actual current $DISPLAY setting?

> > Sometimes it hangs when doing signing locally (DISPLAY is normal,
> > running from terminal). Right now it's happening when I try to use gpg
> > on a remote machine accessed via SSH. Happens with mutt, and also with
> > dpkg-buildpackage.
> does it also happen with gpg on its own (without mutt, without
> dpkg-buildpackage)?  What version of gnupg is installed?

Yes. Running git-buildpackage -> hang


> What's going on on the rest of the system?  Does this machine have

Nothing special, an amd64 system with Sid although partly behind the
latest state, last dist-upgrade happened last week or so.

> dbus-user-session installed?

ii  dbus-user-session                          1.10.12-1                  all                        simple interprocess messaging system (systemd --user integration)

> What version of pinentry is configured by default?

What's pinentry again? No mention of it in /usr/share/doc/gnupg-agent/README.Debian :-(

Now when you mention it, I can explore more. And documentation is bad,
sorry. How I see that it's managed by alternatives (how should a user
guess that??) and this seems to be what you mean with version...

ii  pinentry-curses                            0.9.7-6                    amd64                      curses-based PIN or pass-phrase entry dialog for GnuPG
ii  pinentry-gnome3                            0.9.7-6                    amd64                      GNOME 3 PIN or pass-phrase entry dialog for GnuPG
ii  pinentry-gtk2                              0.9.7-6                    amd64                      GTK+-2-based PIN or pass-phrase entry dialog for GnuPG
ii  pinentry-qt                                0.9.7-6                    amd64                      Qt-based PIN or pass-phrase entry dialog for GnuPG

And it was pointing to the gnome3 version. So I changed it to
pinentry-curses. Still not working, hanging. Killed gpg-agent. NOW it works.

(curses version works, gtk2 works, qt works, although slow loading over
remote link)

> How is gpg-agent being restarted (you mentioned "Restarting
> gpg-agent")?

killall or "gpgconf --kill gpg-agent", does not seem to make any

> Thanks for any details you can provide,

Well, sorry for inconvenience, I see things more clear now. But, as
said, with my basic user hat on, this looks quite intransparent and like
the fault of gnupg. Or even gnupg-agent (once you start looking deeper
and wonder why --no-use-agent is a noop switch now).

Best Regards,

More information about the pkg-gnupg-maint mailing list