[pkg-gnupg-maint] Bug#865824: gnupg hangs during import of keys (bis)

Raphaël raphael.droz at gmail.com
Sun Jun 25 03:16:22 UTC 2017

Package: gnupg
Version: 2.1.18-6
Severity: normal

Dear Maintainer,

While trying to convert pubring.gpg into pubring.kbx I did the following
$ gpg --import-options import-local-sigs --import /tmp/xxx
# /tmp/xxx being a copy of pubring.gpg
as advised here https://www.gnupg.org/faq/whats-new-in-2.1.html#keybox

I found that the import worked "once at a time", I mean it imports one
signature then hang => ^C and rerun.

Running using --debug-all, I found the following message just before it

gpg: DBG: parse_packet(iob=107): type=2 length=79 (parse.../../g10/keydb.c.1177)
gpg: DBG: iobuf-107.0: underflow: buffer size: 8257; still buffered: 0 => space for 8257 bytes
gpg: DBG: iobuf-107.0: close '?

# or during the next run (one sig imported, the next one hanging):
gpg: DBG: parse_packet(iob=468): type=2 length=105 (parse.../../g10/keydb.c.1177)
gpg: DBG: parse_packet(iob=468): type=14 length=269 (parse.../../g10/keydb.c.1177)
gpg: DBG: parse_packet(iob=468): type=2 length=76 (parse.../../g10/keydb.c.1177)
gpg: DBG: iobuf-468.0: underflow: buffer size: 137594; still buffered: 0 => space for 137594 bytes
gpg: DBG: iobuf-468.0: close '?'

# another run (one sig imported, the next one hanging):
gpg: DBG: parse_packet(iob=287): type=14 length=1037 (parse.../../g10/keydb.c.1177)
gpg: DBG: parse_packet(iob=287): type=2 length=76 (parse.../../g10/keydb.c.1177)
gpg: DBG: parse_packet(iob=287): type=2 length=88 (parse.../../g10/keydb.c.1177)
gpg: DBG: iobuf-287.0: underflow: buffer size: 64279; still buffered: 0 => space for 64279 bytes
gpg: DBG: iobuf-287.0: close '?'

Same result when removing gpg.conf or trying various import-options (import-minimal, import-clean)

But --import-options import-export successfully export a GPG traditional pubring file (not a GPG keybox) containing the 124 signatures.

See also: #841103

-- System Information:
Debian Release: 9.0
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-debug'), (500, 'oldstable-updates'), (500, 'oldstable'), (90, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-0.bpo.3-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE=fr_FR:fr (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages gnupg depends on:
ii  gnupg-agent    2.1.18-6
ii  libassuan0     2.4.3-2
ii  libbz2-1.0     1.0.6-8.1
ii  libc6          2.24-11+deb9u1
ii  libgcrypt20    1.7.6-2
ii  libgpg-error0  1.26-2
ii  libksba8       1.3.5-2
ii  libreadline7   7.0-3
ii  libsqlite3-0   3.16.2-5
ii  zlib1g         1:1.2.8.dfsg-5

Versions of packages gnupg recommends:
ii  dirmngr     2.1.18-6
pn  gnupg-l10n  <none>

Versions of packages gnupg suggests:
pn  parcimonie  <none>
pn  xloadimage  <none>

-- no debconf information

More information about the pkg-gnupg-maint mailing list