gnutls 2.10.5-2 and 2.12.7-1 on ARM are failing with PSK

Hardy Griech ntbox at
Wed Jul 13 20:04:01 UTC 2011

On 13.07.2011 19:39, Andreas Metzler wrote:
> On 2011-07-09 Andreas Metzler<ametzler at>  wrote:
> [...]
>> I have tried building gnutls 2.10.5 on (the debian
>> ARMEL porterbox). The build stalled when running the testsuite,
>> getting stuck running the mini test. I have submitted this upstream.
> There is also

I can confirm your observations: today I had some time for debugging the 
issue and my findings were too, that libgcrypt is the culprit.

Removing --with-libgcrypt from debian/rules from the build directory and 
then rebuilding it creates *.deb files - all other tries failed during 
"make check-TESTS".  Installation of those packages makes apache work 
with TLS-PSK again.

"Funny", that AES is broken with gcc4.6...


PS: have you tried gcc4.6.1-3 to build libgcrypt?

PPS: why don't you use nettle as crypto library?

More information about the Pkg-gnutls-maint mailing list