Bug#653400: ktorrent-1.1.3 not starting
ametzler at downhill.at.eu.org
Sun Feb 26 09:23:21 UTC 2012
reassign 653400 libktorrent3 1.1.3-1
tags 653400 patch
retitle 653400 libktorrent3 gcry_check_version too strict, overriding shlibs system
On 2012-02-25 Modestas Vainius <modax at debian.org> wrote:
> reassign 653400 libgcrypt11 1.5.0-3
> On šeštadienis 25 Vasaris 2012 20:50:43 Mikhail Balabin wrote:
> > So, the problem was tracked down to incorrect library dependency.
> > Currently the package libktorrent3 (version 1.1.3-1) has a requirement
> > libgcrypt11>=1.4.5, but the correct dependency is libgcrypt11>=1.5.0,
> > perhaps. I suggest the package maintainer to upload an updated
> > libktorrent3 package with adjusted dependency in order to close the
> > bug.
> If anything it means that libgcrypt11 1.5.0 must enforce stricter
> dependency via shlibs/symbol file as it's not backwards compatible.
> libktorrent 1.1.3-1 has been built against libgcrypt11 1.5.0 but
> gained libgcrypt11 (>= 1.4.5) dep.
the cause of the breakage is this line in src/util/functions.cpp
The macro GCRYPT_VERSION is expanded *at* *build* *time*. Therefore if
you build against 1.5.0 you end up with gcry_check_version("1.5.0"),
which fails (by design) when running against 1.4.6.
My advise would be to use the gcrypt version that libktorrent3 requires
instead of hardcoding the version it was built against.
Just specifying something non-ancient should work, e.g. 1.4.5:
- if (!gcry_check_version(GCRYPT_VERSION))
+ if (!gcry_check_version("1.4.5"))
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'
More information about the Pkg-gnutls-maint