[pkg-go] Bug#931401: syncthing: incorrect warning please upgrade to v0.14.14 or newer

dirdi debian at dirdi.name
Sat Feb 29 00:17:25 GMT 2020


Package: syncthing
Version: 1.1.4~ds1-4
Followup-For: Bug #931401

Just want to confirm Joaquín's assumption that the package was built
with a wrong version string:

$ strings /usr/bin/syncthing | grep unknown-dev
_eval_args_additionalsalarm clockalloc_spaceaudio/basicaudit-*.logauthoritiesbad addressbad messagebad timedivbad verb '%broken pipebytes fieldcall of nilcgocall nilcircledast;clobberfreecomplement;connectionscontentionscontextmenucreated by crossorigincurlywedge;customtype=delete filedoubleStarsdynamicAddrempty fieldeqslantgtr;expected :=file existsfinal tokenfloat32nan2float64nan2float64nan3folderLabelformenctypegccheckmarkglobalBytesglobalFilesgtreqqless;gui-addresshash error:http-serverhttps_proxyi/o timeoutignorePermsignoreStatsinSyncBytesinSyncFilesindex-blockinuse_spaceis disabledisCandidatejournal-numld [x + %d]lessapprox;lesseqqgtr;linux-amd64listenLocallmoustache;local errorlocal.protolongVersionlongmapsto;lost mcachemSpanManualmapstodown;mapstoleft;memdb at flushmethodargs(nLeftarrow;nanosecondsneedDeletesnewestFirstnil contextnleftarrow;not reachednot startednsubseteqq;nsupseteqq;oldestFirston write topanic-*.logparse errorpermissionsplaceholderprecapprox;prevVersionrange_closeraw-controlreceiveonlyreflect.SetrescanIntvsretry-afterrightarrow;rmoustache;runtime: P runtime: p save configscheddetailsendreceivesetnonblockshort writesqsubseteq;sqsupseteq;stack faultstack tracestat after:subsetneqq;succapprox;supsetneqq;syncDir: %vtable at buildterms_closetime: file tls: alert(tracealloc(traffic updtrashcan@%punknown-devunreachableunsubscribeupuparrows;valid untilvarepsilon;varnothing;weak hasherzero header~syncthing~  addresses: (sensitive) PRIVATE KEY [recovered] allocCount  found at *( gcscandone  m->gsignal= minTrigger= nDataRoots= nSpanRoots= pages/byte

Did one figure out a workaround?

Btw: The bug was reported upstream, too: https://forum.syncthing.net/t/odd-not-sending-symlinks-to-old-client-messages-on-debian/14254
But was closed since this is clearly a debian specific issue.

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (500, 'testing'), (50, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.4.0-4-amd64 (SMP w/8 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages syncthing depends on:
ii  libc6  2.29-10

syncthing recommends no packages.

syncthing suggests no packages.

-- no debconf information


More information about the Pkg-go-maintainers mailing list