[pkg-go] Bug#1004289: libpod package stops buld at override_dh_auto_build

Elimar Riesebieter riesebie at lxtec.de
Mon Jan 24 12:21:21 GMT 2022

Source: libpod
Version: 3.4.4=ds1
Severity: important
X-Debbugs-Cc: hostmasters at hostsharing.net

Dear Maintainers,

I tried to backport libpod in bullseye. The build-dep's are installed
in two steps: apt build-dep libpod && apt build-dep -t unstable
libpod. The build stops at:

dh_auto_build: error: cd _output && go install -trimpath -v -p 20 -tags apparmor,ostree,seccomp,selinux,systemd -ldflags "-X main.buildInfo=3.4.4+ds1-1" github.com....

make[1]: *** [debian/rules:29: override_dh_auto_build] Error 25
make[1]: Leaving directory '/source/podman/libpod-3.4.4+ds1'
make: *** [debian/rules:25: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
debuild: fatal error at line 1182:
dpkg-buildpackage -us -uc -ui failed

The very same error is triggered by building version 3.0.1+dfsg1.

Did that in a bullseye environment and in a pbuilder chroot.


-- System Information:
Debian Release: 11.2
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-updates'), (500, 'stable-security'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.15.0-0.bpo.2-amd64 (SMP w/20 CPU threads)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

More information about the Pkg-go-maintainers mailing list