<div dir="ltr">Hello, <div><br></div>> postgis (2.3.0+dfsg-2) unstable; urgency=medium<br>>  * Update pgversions to require PostgreSQL 9.2 or newer.<br>>  * Run tests against all supported PostgreSQL versions.<br>>  * Downgrade the dependency from the extension package to the<br>>    scripts package to a recommendation, so the former becomes<br>>    co-installable with older versions, again. Closes: #839182.<br>> -- Markus Wanner <<a href="mailto:markus@bluegap.ch">markus@bluegap.ch</a>>  Fri, 30 Sep 2016 16:36:08 +0200<div><br></div><div>I see a new 2.3 release has been pushed, which is awesome and fixes the immediate 2.3 issue. However, postgis-2.2 still requires `postgresql-9.4-postgis-2.2-scripts`, which conflicts with the package that postgis-2.1 requires, which is `postgresql-9.4-postgis-scripts`, which requires `postgresql-9.4-postgis-2.3-scripts`</div><div><br></div><div>Can postgis-2.2 either require `postgresql-9.4-postgis-scripts` or move `postgresql-9.4-postgis-2.2-scripts` to `Recommends`?</div><div><br></div><div><br></div><div><div># apt-get install -y --no-install-recommends \</div><div>>     postgresql-9.4-postgis-2.1                                  \</div><div>>     postgresql-9.4-postgis-2.2                                  \</div><div>>     postgresql-9.4-postgis-2.3                                  \</div><div>>     postgresql-9.4-postgis-scripts</div><div>Reading package lists... Done</div><div>Building dependency tree</div><div>Reading state information... Done</div><div>Some packages could not be installed. This may mean that you have</div><div>requested an impossible situation or if you are using the unstable</div><div>distribution that some required packages have not yet been created</div><div>or been moved out of Incoming.</div><div>The following information may help to resolve the situation:</div><div><br></div><div>The following packages have unmet dependencies:</div><div> postgresql-9.4-postgis-2.2 : Depends: postgresql-9.4-postgis-2.2-scripts but it is not going to be installed</div><div>E: Unable to correct problems, you have held broken packages.</div><div># apt-cache policy \</div><div><div>>     postgresql-9.4-postgis-2.1                                  \</div><div>>     postgresql-9.4-postgis-2.2                                  \</div><div>>     postgresql-9.4-postgis-2.3                                  \</div><div>>     postgresql-9.4-postgis-scripts</div></div><div>postgresql-9.4-postgis-2.1:</div><div>  Installed: (none)</div><div>  Candidate: 2.1.8+dfsg-5~97.git43a09cc.pgdg14.04+1</div><div>  Version table:</div><div>     2.1.8+dfsg-5~97.git43a09cc.pgdg14.04+1 0</div><div>        500 <a href="http://apt.postgresql.org/pub/repos/apt/">http://apt.postgresql.org/pub/repos/apt/</a> trusty-pgdg/main amd64 Packages</div><div>     2.1.5+dfsg-2heroku1 0</div><div>        500 <a href="https://packagecloud.io/heroku/dod/ubuntu/">https://packagecloud.io/heroku/dod/ubuntu/</a> trusty/main amd64 Packages</div><div>postgresql-9.4-postgis-2.2:</div><div>  Installed: (none)</div><div>  Candidate: 2.2.2+dfsg-5.pgdg14.04+1</div><div>  Version table:</div><div>     2.2.2+dfsg-5.pgdg14.04+1 0</div><div>        500 <a href="http://apt.postgresql.org/pub/repos/apt/">http://apt.postgresql.org/pub/repos/apt/</a> trusty-pgdg/main amd64 Packages</div><div>postgresql-9.4-postgis-2.3:</div><div>  Installed: (none)</div><div>  Candidate: 2.3.0+dfsg-2.pgdg14.04+1</div><div>  Version table:</div><div>     2.3.0+dfsg-2.pgdg14.04+1 0</div><div>        500 <a href="http://apt.postgresql.org/pub/repos/apt/">http://apt.postgresql.org/pub/repos/apt/</a> trusty-pgdg/main amd64 Packages</div><div>postgresql-9.4-postgis-scripts:</div><div>  Installed: (none)</div><div>  Candidate: 2.3.0+dfsg-2.pgdg14.04+1</div><div>  Version table:</div><div>     2.3.0+dfsg-2.pgdg14.04+1 0</div><div>        500 <a href="http://apt.postgresql.org/pub/repos/apt/">http://apt.postgresql.org/pub/repos/apt/</a> trusty-pgdg/main amd64 Packages</div></div><div><div># apt-cache depends  \</div><div><div>>     postgresql-9.4-postgis-2.1                                  \</div><div>>     postgresql-9.4-postgis-2.2                                  \</div><div>>     postgresql-9.4-postgis-2.3                                  \</div><div>>     postgresql-9.4-postgis-scripts</div></div><div>postgresql-9.4-postgis-2.1</div><div>  Depends: libc6</div><div>  Depends: libgdal1h</div><div>  Depends: libgeos-c1</div><div>  Depends: liblwgeom-2.1.8</div><div>  Depends: libproj0</div><div>  Depends: libxml2</div><div>  Depends: postgresql-9.4</div><div>  Depends: postgresql-9.4-postgis-scripts</div><div>  Suggests: postgis</div><div>  Recommends: postgresql-contrib-9.4</div><div>  Breaks: postgis</div><div>postgresql-9.4-postgis-2.2</div><div>  Depends: libc6</div><div>  Depends: libgdal1h</div><div>  Depends: libgeos-c1</div><div>  Depends: libjson-c2</div><div>  Depends: liblwgeom-2.2-5</div><div>  Depends: libpcre3</div><div>  Depends: libproj0</div><div>  Depends: libxml2</div><div>  Depends: postgresql-9.4</div><div>  Depends: postgresql-9.4-postgis-2.2-scripts</div><div>  Suggests: postgis</div><div>  Recommends: postgresql-contrib-9.4</div><div>  Breaks: postgis</div><div>postgresql-9.4-postgis-2.3</div><div>  Depends: libc6</div><div>  Depends: libgdal1h</div><div>  Depends: libgeos-c1</div><div>  Depends: libjson-c2</div><div>  Depends: liblwgeom-2.3-0</div><div>  Depends: libpcre3</div><div>  Depends: libproj0</div><div>  Depends: libxml2</div><div>  Depends: postgresql-9.4</div><div>  Suggests: postgis</div><div>  Recommends: postgresql-9.4-postgis-2.3-scripts</div><div>  Recommends: postgresql-contrib-9.4</div><div>  Breaks: postgis</div><div>postgresql-9.4-postgis-scripts</div><div>  Depends: postgresql-9.4-postgis-2.3-scripts</div></div></div>