Bug#544155: [grub-pc] grub update renders system unbootable (unaligned pointer 0x700ba)

Felix Zielcke fzielcke at z-51.de
Sat Aug 29 09:41:10 UTC 2009

notfound 544155 1.96+20090317-1
found 544155 1.96+20090826-3
severity 544155 important

Am Samstag, den 29.08.2009, 11:14 +0200 schrieb Martin Steigerwald:
> Package: grub-pc
> Version: 1.96+20090317-1
> Severity: grave
> --- Please enter the report below this line. ---
> Note: This bug report is for 1.96+20090826-3, I downgraded to the squeeze 
> version to make system bootable again.

If you report a bug bug for a different version then the one on
currently running on your system, you should change the Version: pseudo
header so that the BTS knows this too.

> I just let aptitude update grub-pc to 1.96+20090826-3. I do not know the 
> earlier version, but I guess it was one version before, cause if I still 
> had the squeeze one it wouldn't have updated to the unstable 
> automatically.
> On booting up today I got:
> [Linux-bzImage, setup=0x2c00, size=0x25a070]
> vga=792 is deprecated. Use set gfxpayload=1024x768x24,1024x768 before 
> linux command instead.
> unaligned pointer 0x700ba
> Aborted. Press any key to exit.Operating system not found
> I also tried with another kernel with the same result.

With what kernel?

> Then I booted into grml, overwrote the swap partition and recreated it via 
> mkswap in order to make sure the TuxOnIce snapshot is invalidated to avoid 
> data loss in next boot.
> Then I chrooted to my debian system after bind mounting /dev, /proc, /sys 
> to it, downgraded grub-pc to 1.96+20090317-1 from squeeze and ran grub-
> install.
> I thought about running grub-install for the grub-pc from unstable, but I 
> read the current sid version might be broken anyway[1], thus I thought I'd 
> better downgrade to the squeeze one in order to get a working system 
> quickly again. I could try updating to the sid one again, without running 
> grub-install manually and then I run it manually and see whether it fixes 
> the issue. So you could know whether its grub itself or a missing grub-
> install.

If grub-install doestn't get run then /boot/grub still has the old grub
and so nothing actually changed, except if grub-mkconfig generates a
different grub.cfg.

> Anyway the expected result is: After an update of grub-pc package the 
> system boots up manually. Thus if a new version is incompatible to the old 
> stage 1 the upgrade process has to force a grub-install IMHO or at least 
> strongly recommend it. I don't remember seeing anything about this in 
> debconf questions. And if a new version of grub-pc doesn't work on my 
> ThinkPad T42 it shouldn´t enter testing ;)

We have already a debconf prompt for running grub-install.
If I reverse the if of the postinst correctly, then it gets shown
if /boot/grub/stage2 or /boot/grub/menu.lst doestn't exist
or /boot/grub/core.img exists.
So at least if grub-install from grub2 were run once.
Debconf prompts are by design only shown once, if you then want to see
it again you'd need to run `dpkg-reconfigure grub-pc'.

> This is on an IBM ThinkPad T42.
> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=540125#75

I should have mentioned that I meant the 1.96+20090825-1 and 1.96
+20090826-1 at that time currently in sid and not the 1.96+20090826-3.

> Regards,
> Martin
> --- System information. ---
> Architecture: i386
> Kernel:       Linux 2.6.31-rc7-tp42-toi-3.0.1-04741-g57e61c0

The new Linux loader seems to have problems with 2.6.31 kernel, though
the Ubuntu default kernel works with it.
You should be able to load it with the old one: linux16 and initrd16.

Felix Zielcke
Proud Debian Maintainer

More information about the Pkg-grub-devel mailing list