[Pkg-haskell-maintainers] Bug#538098: Bug#538098: Please upgrade to ≥0.5.1.0.
Trent W. Buck
twb at cybersource.com.au
Fri Jul 24 02:14:55 UTC 2009
On Thu, Jul 23, 2009 at 10:32:09AM +0200, Joachim Breitner wrote:
>> Package: libghc6-zlib-dev
>> Version: 0.5.0.0-2+b1
>> Severity: wishlist
>> Please upgrade haskell-zlib in Debian. The upcoming release of
>> Darcs 2.3 requires haskell-zlib 0.5.1.0.
>> Without it, Darcs will use its deprecated internal zlib bindings,
>> which will reduce the amount of real-world testing that
>> haskell-zlib gets from Debian users.
> now it starts: The platform specifies zlib-0.5.0.0... but using
> something deprecated should be avoided.
I believe the reason Darcs' zlib dependency was bumped to 0.5.1 is
because 0.5.0 has known problems with CRC (checksums) -- either
generating bad ones, or failing to detect/repair bad ones.
I can dig up the exact details if you want.
More information about the Pkg-haskell-maintainers