Bug#342341: eclipse: too many unneeded dependencies

Andrew Vaughan ajv-lists at netspace.net.au
Wed Dec 14 11:59:12 UTC 2005

Hi everyone.
[Erwan, this mail is for the eclipse maintainers.  I've kept you cc'ed 
to keep you in the discussion.]

On Wed, 14 Dec 2005 19:32, Erwan David wrote:
> And that doies not explain th gnome dependency, which is heavier, and
> tottaly inadequate and, I repeat DANGEROUS.

I have an eclipse.org binary release (3.1.1) unpacked in ~/bin/eclipse on my 
sarge install.  A quick search shows that this includes private libraries.  

$ find /home/andrew/bin/eclipse/  |grep '\.so\.\|\.so$'

(Obviously this is something that the debian eclipse packages don't do). 

A quick ldd shows that the private libraries upstream ships _are_ linked 
against gnome libs.

ldd /home/andrew/bin/eclipse/configuration/org.eclipse.osgi/bundles/33/1/.cp/libswt-gnome-gtk-3139.so|
grep gnome
        libgnomevfs-2.so.0 => /usr/lib/libgnomevfs-2.so.0 (0x4001b000)
        libgnome-2.so.0 => /usr/lib/libgnome-2.so.0 (0x4007d000)
        libgnomeui-2.so.0 => /usr/lib/libgnomeui-2.so.0 (0x40092000)
        libgnomecanvas-2.so.0 => /usr/lib/libgnomecanvas-2.so.0 (0x4067b000)
        libgnome-keyring.so.0 => /usr/lib/libgnome-keyring.so.0 (0x40ac0000)

a quick google search "site:eclipse.org libgnome" reveals 36 hits.  The 
following 2 (at least) support the argument that the gnome libraries are (or 
at least were) used upstream.


However it ain't that simple.  There has recently been a thread about unused  
library dependencies [1], [2]. 

The sarge ldd command does not have the -u option.  Therefore I tried ldd -u 
on ubuntu.

-u /home/andrew/bin/eclipse/configuration/org.eclipse.osgi/bundles/33/1/.cp/libswt-gnome-gtk-3139.so
Unused direct dependencies:


At this point I'm out of my depth.  I don't know how to determine whether 
(upstreams) libswt-gnome-gtk-3139.so actually _should_ be linked against 
gnome libs.  Since I'm running sarge, it haven't tried ldd on the debian swt 

I did try the following.

1. Rename /usr/lib/libgnomevfs-2.so.0, /usr/lib/libgnome-2.so.0, 
2. Reboot.
3. kde apps all seem fine.
   gedit fails needing libgnomeui-2.so.0.
   eclipse seems fine.  Confirmed basic open, edit, save functionality works.
   eclipse help also works (uses mozilla-firefox, but this is what 
   /etc/alternatives/mozilla points to).  
   I did not test any other functionality.  Important eclipse functionality 
could easily be broken.

Hence it seems that eclipse does not need gnome libs for basic functionality.  
The above test doesn't mean that other swt apps don't use functionality from 
gnome libs of course. 

Andrew V.

[1] http://lists.debian.org/debian-devel-announce/2005/11/msg00016.html
[2] http://lists.debian.org/debian-devel/2005/11/msg01427.html

More information about the pkg-java-maintainers mailing list