maven2 2.0.8-1 fails to work at all.

Fred Cooke fred.cooke at
Fri Dec 14 20:37:37 UTC 2007

Hi, this is the first time in 5 years of using debian i have had any
issues that i couldnt solve, so I'm a little hesitant to post about it

fred at rwdlsd:~$ mvn
Exception in thread "main" java.lang.IllegalAccessError: tried to
access field org.codehaus.plexus.util.Os.OS_NAME from class
	at org.apache.maven.cli.MavenCli.<clinit>(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.lang.reflect.Method.invoke(
	at org.codehaus.classworlds.Launcher.launchEnhanced(
	at org.codehaus.classworlds.Launcher.launch(
	at org.codehaus.classworlds.Launcher.mainWithExitCode(
	at org.codehaus.classworlds.Launcher.main(

is all it ever does regardless of arguments. i tried -X and -e and
combined together also.

i've got these java packages installed :

rwdlsd:/var/cache/apt/archives# l sun-java6-*
-rw-r--r-- 1 root root 26414096 2007-10-04 07:02 sun-java6-bin_6-03-2_i386.deb
-rw-r--r-- 1 root root    40708 2007-10-04 07:02 sun-java6-doc_6-03-2_all.deb
-rw-r--r-- 1 root root     1814 2007-10-04 07:02 sun-java6-fonts_6-03-2_all.deb
-rw-r--r-- 1 root root  9508894 2007-10-04 07:02 sun-java6-jdk_6-03-2_i386.deb
-rw-r--r-- 1 root root  6327332 2007-10-04 07:02 sun-java6-jre_6-03-2_all.deb
-rw-r--r-- 1 root root     1596 2007-10-04 07:02

please let me know if there is anything else i can do to help diagnose this.

2.0.7-2 works fine for me in all ways, and i'll continue to use that
for the time being.

i also have some (more important to me) issues with eclipse which i
will now post seperately.



More information about the pkg-java-maintainers mailing list