Bug#442246: Please don't force using gcj-4.1 when building libgui-commands-java

Riku Voipio riku.voipio at iki.fi
Fri Sep 14 11:47:32 UTC 2007

Package: libgui-commands-java
Version: 1.1.43-1
Severity: normal
User: debian-arm at lists.debian.org
Tags: eabi

Currently libgui-commands-java explictly requires gcj-4.1, which is
not available on armel port. The packaging fails to explain why it
is neccesary to build-depend on a specific version of gcj when
building, instead of relying on the gcj provided by
java-gcj-compat-dev. java-gcj-compat-dev currently depends on gcj-4.2,
which is available for armel.

On Fri, Sep 14, 2007 at 02:33:22PM +0300, Source Builder wrote:
> Build-Depends: debhelper (>> 5.0.0), cdbs, patchutils, ant, java-gcj-compat-dev, gcj-4.1, libjaxen-java

> E: Package gcj-4.1 has no installation candidate

More information about the pkg-java-maintainers mailing list