Bug#442465: Please don't force using gcj-4.1 when building libjmathtex-java

Riku Voipio riku.voipio at iki.fi
Sun Sep 16 11:25:09 UTC 2007

Package: libjmathtex-java
Version: 0.7~pre-1
Severity: normal
User: debian-arm at lists.debian.org
Tags: eabi

Currently libjmathtex-java explictly requires gcj-4.1, which is
not available on armel port. The packaging fails to explain why it
is neccesary to build-depend on a specific version of gcj when
building, instead of relying on the gcj provided by
java-gcj-compat-dev. java-gcj-compat-dev currently depends on gcj-4.2,
which is available for armel.

> Build-Depends: debhelper (>> 5.0.0), cdbs, patchutils, ant, java-gcj-compat-dev, gcj-4.1, libjdom1-java

> E: Package gcj-4.1 has no installation candidate
> apt-get failed.
> Package installation failed
> Trying to reinstall removed packages:
> Trying to uninstall newly installed packages:
> Source-dependencies not satisfied; skipping libjmathtex-java
> ******************************************************************************
> Finished at 20070916-1415
> Build needed 00:06:30, 8844k disk space

More information about the pkg-java-maintainers mailing list