Bug#432541: eclipse-cdt FTBFS with gcj-4.2

Andrew Haley aph at redhat.com
Sun Feb 17 13:51:16 UTC 2008

Michael Koch wrote:
> On Sat, Feb 16, 2008 at 10:33:21AM +0000, Andrew Haley wrote:
>> Michael Koch wrote:
>>> On Sat, Feb 16, 2008 at 09:56:18AM +0000, Andrew Haley wrote:
>>>> Has anyone actually attempted to debug this?  Which code actually calls
>>>> Runtime.exit()?
>>> I tried to debug this but I dont found out from where exit is called
>>> with code 13.
>> What went wrong with the debugging?  Do you want me to look?
> I was not able top get proper backtraces. All I found was that
> exit_group(13) was called.

So, no-one has actually tried to debug this.

>>>> I'm betting it's a bogus version check.
>>> What kind of version check do you mean?
>> As far as I'm aware, OSGI bundles are versioned and if an
>> appropriate OSGI bundle version is not found the program exits.
> That doesnt explain why the build always worked with SUN JDK. It should
> have failed the same if OSGi versions would be a problem. Wouldn't it?

Did you try it with OpenJDK (the Sun version with the binary plugs) ?
This is an important test.


More information about the pkg-java-maintainers mailing list