[Pkg-javascript-commits] [node-leveldown] tag 0.1.2 created (now cb40dac)

Andrew Kelley andrewrk-guest at moszumanska.debian.org
Sun Jul 6 17:15:49 UTC 2014


This is an automated email from the git hooks/post-receive script.

andrewrk-guest pushed a change to tag 0.1.2
in repository node-leveldown.

        at  cb40dac   (commit)
This tag includes the following new commits:

       new  418bbe2   initial commit
       new  7ee13ba   async all the things! better C++ organisation
       new  d18dfaf   del() support, rename read/write to get/put
       new  a3e5388   batch writes!
       new  9a1271c   buffers, encoding, persistent handles
       new  67cfe1c   binary data tests
       new  254b6a2   batch binary, improved batch interface
       new  d8ac739   better memory management for batch()
       new  fb58afe   iterator -> ReadStream, WriteStream for put/batch
       new  13f4712   (mostly) complete basic stream implementations
       new  6e925e6   proper gyp build inc leveldb & snappy
       new  657e882   gyp simplify
       new  4b62157   add licence & copyright
       new  4c9544b   snappy tarball
       new  febbc32   mac build, linux flags
       new  d5592a5   copy() using pipe() with test
       new  dd0e961   objects defined using 'Creator'
       new  9cc3ea4   simplify setUp/tearDown, extend timeout
       new  4785517   fstream serialize/deserialize functional test
       new  66c377c   remove unused code
       new  59e9ee5   initial README
       new  6966e96   cleaned up & improved options ({}) handling
       new  579e29d   minor readme tweaks
       new  92439e6   expanded README
       new  37a840f   minor touchups and 0.0.0 release to npm
       new  95b1537   basic ReadStream and WriteStream documentation
       new  afb0222   remove 'inherits', add extras deps to package.json
       new  699a0f1   'start' and 'end' options for ReadStreams
       new  0488223   new API, levelup(loc, opt, function (err, db) {})
       new  def2a4a   remove global garbage
       new  bffc5b7   json encoding!
       new  896ce84   extra tests for non-existant start position
       new  8f9fdf3   keywords!
       new  65b4c3b   updated documentation for latest version & new API
       new  8e82cd8   version bump
       new  e4109b8   typo
       new  02a2983   don't encourage async `throw`
       new  a7c67c7   typo, "NOT suitable for multiprocess"
       new  c57374c   return to classical prototypal classes
       new  736f4c4   version bump
       new  8855ccf   add repo info to package.json
       new  9291248   reversable ReadStreams
       new  bd20bda   version bump
       new  b9f98ad   fix ReadStream bug -- encoding options not passed
       new  b2771fd   version bump
       new  36cfc3a   un-focus-arrow
       new  1bf455b   code cleanup
       new  5f3685a   native layer error on null||undefined key||value
       new  a8f8efd   version bump
       new  56078b7   minor fix to package.json
       new  4c08cab   add travis setup
       new  522cc02   KeyStream and ValueStream, version bump to 0.1.0
       new  6eb361d   ensure readStream options NOT sticky
       new  9875777   version bump
       new  5dcbc5b   falsey start/end on readstream kill proc, fixes #8
       new  50dbf2a   version bump
       new  cda19e5   solaris / sunos / smartos support
       new  0f0a554   version bump
       new  39b44bc   fix db GC when using ReadStream x 2
       new  a3d846d   version bump
       new  1835bbf   undo focus rocket
       new  a34fb35   Node 0.9 copy() bug, needs further investigation
       new  bc7f266   document events
       new  a09960f   minor edits
       new  4c6d620   turned LevelUP into an OPEN Open Source Project
       new  ee6cd20   run the encoding on start and end in case your keys are JSON encoded
       new  5a25249   Merge pull request #21 from Raynos/encode-stream
       new  dfe0593   levelup() should return a db object
       new  1139558   status state machine to make close semantics correct
       new  4c0d189   if closing call callback after closed
       new  a56a380   cleanup & complete & add tests for deferred ops
       new  2ff58a7   remove console.log in test
       new  b93b6e5   remove more debugging guff
       new  c99956d   fix deferred batch: !isOpen() && !isClosed()
       new  3fe67be   Merge pull request #22 from rvagg/open-deferred
       new  9392354   beefed up README
       new  09477db   minor typo
       new  8f51df5   version bump to 0.3.0
       new  8664173   remove floating streams header from readme
       new  8603b3e   added basic benchmark suite
       new  6549f1c   added focus-arrow to benchmark suite
       new  487d614   single-put batch benchmark
       new  d1e7bfe   fix functional test
       new  2fd94d7   implement readStream() `limit` option
       new  99f0351   version bump
       new  7625b82   ignore wip stuff
       new  625ba80   added more functional tests!
       new  101c3a2   travis update
       new  2e6bf80   emit raw values in events
       new  a199ea0   Merge pull request #36 from Raynos/raw-events
       new  a27c152   0.3.2
       new  40dbde6   test for implicit snapshot on readStream()
       new  01b01b0   added snapshot test case that I forgot to add...
       new  9fb87ec   work-around for dodgy slow-stream
       new  9daeeb4   reformat package.json
       new  8da9356   fixed snappy compression, added compression tests
       new  f4c6917   close() callback existential check
       new  469b095   added useBatch=false option on writeStream
       new  f296610   indentification
       new  795aedd   fix up virtual methods & reformat
       new  f97739e   version bump @0.3.3
       new  9dcabe9   Merge tag 'v0.3.3'
       new  f160b90   added `compress` boolean on open()
       new  700ff08   leveldb 1.7
       new  7b907b0   remove compile warnings for solaris
       new  4ff9822   cleaner build for osx
       new  bedf32e   allow JS Strings through to native layer
       new  150c92f   revamped benchmark suite
       new  4d1848c   added leveldb 1.7.0 source tarball
       new  51d7384   added no-compression benchmark engine
       new  7ae020e   improved benchmarks
       new  320845d   minor performance tweaks
       new  5a3192d   slight C++ cleanup, giving in to macros, UGH!
       new  73d44f8   added basic get() benchmarks
       new  c16dabf   optimised encoders & decoders
       new  24effd6   return Strings not Buffers from C++ when possible
       new  f61d55b   minor touchups
       new  2b3288c   remove compile warnings on osx!
       new  6d91d69   version bump
       new  6e5eedd   Merge branch '0.4.0-wip' of github.com:rvagg/node-levelup into 0.4.0-wip
       new  635d12b   added SQLite3 to test suite
       new  8ab00d2   updated benchmarks readme
       new  20583d6   improved compression test
       new  67d6796   fix batch() benchmarks
       new  6ed429e   speed up batch() & allow non-Strings to C++
       new  98e50a7   version bump for @dev release
       new  4d6c79c   remove old, unused util functions
       new  c2f079b   minor code cleanup
       new  0c93dfe   version bump for 0.4.0 release
       new  b11fc4b   remove useBatch option on writeStream
       new  3156fb3   version bump to 0.4.1
       new  4b8cf2c   fixed README
       new  1d42d8a   added @ralphtheninja to contributors list
       new  4e6f878   Get approximate size for a range
       new  81232a3   process.nextTick->setImmediate, Node 0.9.5 compat
       new  a501ee7   proper setImmediate/process.nextTick compatibility
       new  00eb3bf   version bump for @0.4.2 release
       new  be67b0a   documentation for approximateSize()
       new  d9f71aa   style fixes based on review
       new  0ce42c5   Merge pull request #44 from kesla/approximate-size
       new  ea7073b   readme tweak, added @kesla to contributors list
       new  bdc8474   version bump for @0.4.3 release
       new  bae8af6   set maxListeners to Infinity to prevent warnings when using deferred open. fixes #47
       new  59a5fd4   test against console.error() call
       new  936674b   version bump for @0.4.4 release
       new  5c79a0e   use util.inherits() from node core
       new  9237111   feature: Support setting size of LRU-cache
       new  a0892dc   updated contributors
       new  325ee02   Merge pull request #49 from ralphtheninja/util-inherits
       new  a31bf08   fix: check that UINT32_OPTION_VALUE is a Uint32
       new  a66e346   Merge pull request #50 from kesla/cache-options
       new  01bf962   test that open and close are idempotent
       new  ee7175d   idempotent open and close, and emit _state as events
       new  3c2c360   document state events
       new  6e52dc6   minor code style adjustments
       new  1e16508   adjust copyright & contributors
       new  dceaa51   proper cleanup after idempotent test
       new  ee364ca   minor c++ code reorg, move constructors out of .h
       new  92e6e10   use util._extend instead of local variant
       new  aecd564   readme tweaks
       new  364f05e   change createIfMissing default to true
       new  82a6f6c   fix GitHub MD derpery
       new  aa36f47   fix createIfMissing tests for defaults change
       new  6f0e5d5   version bump for 0.5 @dev release
       new  d390426   version bump for release
       new  8faa18b   remove LevelUP components
       new  9e86fc4   rename
       new  95c7521   minor code style tweak
       new  0fd2c8d   minor style tweaks take 2
       new  a2c8dad   callback is not optional for `close()`
       new  98c69c5   complete documentation of current API
       new  bf42af2   version bump for minor additions + docs
       new  18a003e   complete rename from LevelUP to LevelDOWN
       new  6bdcbd8   version bump to 0.0.2
       new  3e19f74   clear out all levelup test stuff
       new  e7ddbeb   fix: incorrect scope in approximateSize func
       new  c39a15c   make scope binding fix far more eloquent
       new  3545866   Merge pull request #60 from sandfox/fix-approximate-size
       new  9a536e8   version bump for @0.5.2 release
       new  daf922a   jshint "onevar":true
       new  2a8f7bf   style tweaks
       new  70c33e4   put LevelUP() into closure
       new  228e26c   comment out all sqlite3 benchmarks
       new  4a3b6a4   jshint one "trailing":true is enough
       new  ef57ce5   code style tweaks
       new  ec95dd0   Merge pull request #1 from rvagg/ralphtheninja-master
       new  547a798   Merge pull request #62 from ralphtheninja/master
       new  ce79ed7   swap bufferstream for simple-bufferstream
       new  2afb590   Merge branch 'master' of github.com:rvagg/node-levelup
       new  02026ac   _location -> location exposed as read-only
       new  2164319   version bump for @0.5.3
       new  8176f8a   fix typo in contributors section
       new  fd96244   move encodingOpts levelup.js -> util.js
       new  f3bdacc   remove useBatch in copy
       new  132cc1a   fix put/batch bug in WriteStream#_process()
       new  a0a1d78   InitializationError -> InitError to reduce line lengths
       new  1493294   Revert "InitializationError -> InitError to reduce line lengths"
       new  9dd22ea   remove CloseError
       new  137bc0e   Merge pull request #70 from rvagg/feature/rm-close-error
       new  f4c7ee0   ensure iterator end & next don't conflict
       new  8b9f5a2   add test-10k-times.sh script
       new  92e24a6   allow one next() at a time, improve end() handling
       new  26ef789   minor style tweaks
       new  ce59488   memory leak, Persistent callback not Disposed
       new  70c1434   explicit namespaces, tighter line wrapping
       new  9e3b56c   added changelog for 0.4.0+
       new  4ab1126   version bump for @0.5.4 release
       new  ff4005d   improve instantiation & open() API
       new  2241480   Merge remote-tracking branch 'levelup/master' into 0.1-wip
       new  eb4c041   fix namespaces
       new  c0224d0   namespace all the things
       new  f981d07   Merge remote-tracking branch 'levelup/master' into 0.1-wip
       new  e565205   complete resync with levelup src
       new  f481221   added initial/basic test suite
       new  2252d94   add --stderr to npm test
       new  3eda5ef   update docs to reflect new reality
       new  4df762d   comprehensive put() tests, made put() more robust
       new  545973a   fix travis config
       new  b879b31   extended put()/get()/del() tests
       new  b157726   tests for basic put/get/del, more args checking
       new  995ba86   approximateSize() tests
       new  0a7b4d5   style tweaks
       new  b5bf23f   add const to LU_STR and LU_OPTION macros
       new  cac083d   move LU_STR() for Database::Batch() closer to usage
       new  6e30030   remove redundant property check
       new  70840b5   Merge pull request #10 from ralphtheninja/0.1-wip
       new  1b0b80f   Merge branch '0.1-wip' of github.com:rvagg/node-leveldown into 0.1-wip
       new  2abf30a   added batch tests
       new  2d6c466   fix keyless batch(), symbol macros to LU_SYMBOL
       new  51f8415   further batch() tests
       new  9468c58   move createIterator to db.iterator, add tests
       new  265bed5   added uber test suite for iterator()
       new  76e93e9   readme update to reflect current code
       new  a5affd4   version bump for @0.1.0 release
       new  8de528e   fix NewInstance args handling, closes #14
       new  54e60fe   version bump for @0.1.1
       new  310a4d1   upgrade to leveldb at 1.9.0 & snappy at 1.1.0
       new  16b7513   add changelog
       new  cb40dac   namespace all macros with LD_

The 239 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "adds" were already present in the repository and have only
been added to this reference.


-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-javascript/node-leveldown.git



More information about the Pkg-javascript-commits mailing list